1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Alarm/ central locking problems on 99 B5

Discussion in 'A4/S4 forum(B5 Chassis)' started by B5_Avant_AAN_Powered, Jun 11, 2010.

  1. B5_Avant_AAN_Powered
    Offline

    B5_Avant_AAN_Powered Member

    Joined:
    Apr 4, 2010
    Messages:
    51
    Likes Received:
    0
    Hi chaps and gals.......

    right, i have a 99 B5 Avant and (even though had engine conversion its been fine for 2 month so we can 100% rule that out lol)

    Went to get in the car today and keyfob didnt work, opened manualy and alarm stayed activated...... i started the car and alarm was still going (on aftermarket managment so factory immob doesnt upset starting)

    couldnt operate lock/unlock from inside and hazards were going mad, once i pulled away after about 2 mins they stopped and doors opened?! But still no keyfob use........ doors will lock all 4 off key but only drivers door opens with key.

    i know c/l pump is fine and it must be a prob elsewhere, no water in n/s footwell and no leaks in pollen filter.

    any ideas as i really need my alarm due to what the car is.

    Thanks in advance lads.

    Sean:sos:
    #1
  2. B5_Avant_AAN_Powered
    Offline

    B5_Avant_AAN_Powered Member

    Joined:
    Apr 4, 2010
    Messages:
    51
    Likes Received:
    0
    Also, wont communicate when i plug in my scanner......
    any fuses or relays that isnt in the o/s fusebox???
    #2
  3. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    Are you using a proper vagcom/VCDS interface, or one of the crappy standalone things?

    If its a standalone thing, get yourself a vagcom cable and see if it makes a better job of talking to the central locking controller.

    If you are using vagcom, sounds like either a wiring fault, or something up with the pump itself.
    #3
  4. B5_Avant_AAN_Powered
    Offline

    B5_Avant_AAN_Powered Member

    Joined:
    Apr 4, 2010
    Messages:
    51
    Likes Received:
    0
    Iuse V checker, VAG only and its spot on, came from AMD i belive.

    sounds like this is gonna be expensive lol
    #4
  5. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,568
    Likes Received:
    267
    I recon you have a problem with a door switch or similar as it would appear the alarm doesnt know the door is open or closed
    #5
  6. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    But the fact that both the remote and the drivers lock dont disarm the car seems very odd to me...

    You've said the drivers door will lock the whole car, Will the remote lock the car?

    If the remote doesnt work at all, then maybe it just needs rematched to the car, and the "unlock" switch in the drivers door is dead?
    #6
  7. B5_Avant_AAN_Powered
    Offline

    B5_Avant_AAN_Powered Member

    Joined:
    Apr 4, 2010
    Messages:
    51
    Likes Received:
    0
    Yeh it is possible i guess!

    remote dont work at all.


    need to get a battery, didnt have any at work
    #7
  8. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    Amusingly, the first thing i'd suggest is resyncing the remote, but to do so, you need two keys and working door lock :D

    Craigs S4 did something very similar. Everything appeared to be working fine, then the remote died. Tried unlocking it from the door, only opened drivers and alarm went off. His is a pre-facelift though, and so has a lock on the passenger door. Unlocking it from there worked fine, so he used that lock to resync the key (once he'd baught a spare) and the remote started working again. Basically the door lock had always been broken, but you simply dont realise because you never use the key.

    I suspect you need to get a multimeter onto the lock microswitch and repair/replace that first, then you'll be able to try resyncing the remote.
    #8
  9. B5_Avant_AAN_Powered
    Offline

    B5_Avant_AAN_Powered Member

    Joined:
    Apr 4, 2010
    Messages:
    51
    Likes Received:
    0
    ok i see, weird one isnt it!

    i only have 1 key but i do have the 3 buttons as a spare, that should work still though right? swopping the buttons but useing the same key "blade" ????

    i let the "blade" go as part of the conversion when i took the blown up TDi motor out ! ******** lol

    Cheers for that Aragon, hit the nail on the head i think.
    Will report back tomorow, going to the garage first thing tomorow

    when the door panels off i can re-seal it as i get a lot of wind noise above 80mph but it gives a cool breeze in the summer lol

    come to think of it the speaker works intermitent in drivers door............ hmmmmmmm wiring issues?!

    can someone give me a hand to put the lid back on this can o worms? PMSL!

    Cheers for the ideas and advice again folks, i may be an excelent motorsport trained mechanic but when it comes to electrics im sadly left in the dark and not ashaimed to admit it

    Sean :yum:
    #9
  10. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    You need two blades mate.

    You need to have the ignition on, then get out and lock the door with the key from the outside (with the ignition still on), then press buttons on the remote to sync it.
    #10
  11. B5_Avant_AAN_Powered
    Offline

    B5_Avant_AAN_Powered Member

    Joined:
    Apr 4, 2010
    Messages:
    51
    Likes Received:
    0
    ok will get new one cut tomorow.

    right stripped the door power to/from lock switch.
    harness fine and power in the joining plugs also.

    got my head battered!

    nobody had any batterys today but im sure it aint that as it used to lock/open all 4 doors off the key a few weeks ago :(
    #11
  12. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    Try emulating the "lock" action by jumpering the appropriate pins on the harness?
    #12
  13. B5_Avant_AAN_Powered
    Offline

    B5_Avant_AAN_Powered Member

    Joined:
    Apr 4, 2010
    Messages:
    51
    Likes Received:
    0
    i sent earths to the harness and it locked but not opened, wiring is fine to the door post join and fine where it goes into the main loom.

    i gave up after 4 hours and put it all back together to be honest!

    just gonna get 2 new batterys tomorow and try to "cheat" by just having the ignition on manualy by powering up the fusebox.

    the clocks arent coded in and there is no engine ECU to sense and i think this is going to make a difference and wont let me code it in.

    just gonna bow down and let my man from AMD to take a look at it.

    i just pul the fuse out and put it back in after 10 secs and all is reset alarm wise but still no working lol

    Will keep you posted on the outcome
    #13
  14. B5_Avant_AAN_Powered
    Offline

    B5_Avant_AAN_Powered Member

    Joined:
    Apr 4, 2010
    Messages:
    51
    Likes Received:
    0
    Right its fixed,
    long story short my man from AMD did his thing and sussed it was a faulty keyfob of all things!!!

    How bizzare.

    cheers for all help and ideas peeps!!
    #14
  15. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,495
    Likes Received:
    299
    Still got to be a faulty lock barrel/microswitch as well surely?

    I cant see how the remote can affect the lock barrel!
    #15
  16. B5_Avant_AAN_Powered
    Offline

    B5_Avant_AAN_Powered Member

    Joined:
    Apr 4, 2010
    Messages:
    51
    Likes Received:
    0
    thats what i thaught but curcuit is complete from rocker switch on lock right through to the pump/control box in the rear 1/4, vagcom showed it is getting signal when opening and closing but when the keyfob went faulty it somehow altered the codes in the system giving 13030 code which is non existant! all working fine now though
    #16

Share This Page