1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Airbag help needed

Discussion in 'A4/S4 forum(B5 Chassis)' started by OllyS4, May 4, 2010.

  1. OllyS4
    Offline

    OllyS4 Member

    Joined:
    Mar 18, 2008
    Messages:
    143
    Likes Received:
    0
    [May 4, 2010]
    My car has always had it's airbag light on and i know the car has had a crash in the past but don't know if the airbags ever went off.
    I've vag-comed it and got

    00588 - Airbag Igniter: Driver Side (N95)

    32-00 - Resistance too High

    00589 - Airbag Igniter 1: Passenger Side (N131)

    32-00 - Resistance too High

    I have soldered the under seat connectors.
    I've changed the control unit and recoded it to my car.
    I've used a volt meter and check the wires going from the control unit to the air bags.
    The air bags look in good condition but don't know how to check then safely.
    Does any one have any ideas what might be wrong and how to check for it?
    #1
  2. Ads

    Ads

    [Sep 21, 2014]

  3. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,573
    Likes Received:
    314
    [May 4, 2010]
    I think thats talking about the main airbags mate, ie the steering wheel and dash ones. Unfortunately you cant really "test" the airbags. Only option is to get another one and swap it in and see if it works. If it doesnt then perhaps its a wiring fault, but you say you've tested the wires.
    #2
  4. OllyS4
    Offline

    OllyS4 Member

    Joined:
    Mar 18, 2008
    Messages:
    143
    Likes Received:
    0
    [May 4, 2010]
    Yeah i think its the dash and the steering wheel, with the bat unplugsed i downloaded the wirring diagram for the airbag system and tesed for ressistance from ther controll unit plug to the airbag plug and both sets of wires are fine.
    I got 1.5 on pas side and 6.8 on drivers side.
    Dose anyone know the part numbers of these 2 airbags?
    I could be a bad pas airbag and the slip ring i.e to seperate faults with the same code.
    Or could it be a bad earth maybe?
    #3
  5. richie_jones
    Offline

    richie_jones Member

    Joined:
    Dec 21, 2008
    Messages:
    49
    Likes Received:
    0
    [May 11, 2010]
    Just incase anybody doesn`t know this I took my car for MOT other day with airbag fault light on and it passed. Guy tells me its not a requirement for the MOT...Not good for safety though....
    #4
  6. OllyS4
    Offline

    OllyS4 Member

    Joined:
    Mar 18, 2008
    Messages:
    143
    Likes Received:
    0
    [May 12, 2010]
    OK to up date. i just bypassed the slipring and the driver side code cleared. So i think that is just the slip ring.
    Now i just need to sort the pas side.
    What part number should i have for the pas side airbag?
    I saw one on ebay for my car but it had a diff number to the one i have in there, could this be the problem?
    #5

Share This Page