1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Airbag fault

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Big Daz, Apr 30, 2010.

  1. Big Daz
    Offline

    Big Daz New Member

    Joined:
    Apr 30, 2010
    Messages:
    6
    Likes Received:
    0
    Had module fixed at airbagforsale.com but the light is still coming on. Codes 02137 battery switch off relay j655. spoke to guys at audi patrs and they've never heard of that relay??
    #1
  2. AidenUK
    Offline

    AidenUK Active Member

    Joined:
    May 27, 2009
    Messages:
    1,647
    Likes Received:
    38
    What other parts have you had replaced?

    I'm assuming you are trying to fix a motor that is smashed?
    #2
  3. Big Daz
    Offline

    Big Daz New Member

    Joined:
    Apr 30, 2010
    Messages:
    6
    Likes Received:
    0
    Yes mate I bought it at auction cat D. It was front drivers was'nt a heavy smash but popped all bags and belts. I sent the module down to airbagsforsale to take out crash data. Ive used them loads of times for other cars and not a problem. Ive tried an other module from same model but makes no differance.
    #3
  4. AidenUK
    Offline

    AidenUK Active Member

    Joined:
    May 27, 2009
    Messages:
    1,647
    Likes Received:
    38
    Thats the reason i asked, have you used the correct seat belts and buckles matched to the chassis number? The reason i ask is because i managed to get a the zip from my coat caught in my drivers side seat belt catch and as ragged the zip out of the catch i broke something on the inside of the catch, as well as leaving a chunk of rubber from the zip inside the catch also :faint:. Because i broke something inside the catch it brought the air bag light on, so i sourced a second hand catch off here from a user called Evolution5, the catch came from an A3 so i thought I'd be laughing once fitted, airbag light would go out etc. Once i fitted it i could use the seat belt and the buckle would click into the catch where as before it wouldn't but the air bag light was still showing, i reset the light numerous times with VAG COM but it still stayed lit, it had to be the catch as it was a different part number to the one which i had broke. I bought a new one from a user on here who gets parts direct from Audi @ discounted prices and whilst purchasing i made sure the new catch was matched to MY chassis number, so once that was fitted the airbag light went out, i didn't even have to reset it again with VAG COM.

    Just a thought mate. :icon_thumright:
    #4
  5. Big Daz
    Offline

    Big Daz New Member

    Joined:
    Apr 30, 2010
    Messages:
    6
    Likes Received:
    0
    Cheers mate, Its all been replaced with belts dash the lot from a German car parts. Its a strange one with the fault coming up as a battery switch off relay!? Turning into a nightmare!!!!
    #5
  6. AidenUK
    Offline

    AidenUK Active Member

    Joined:
    May 27, 2009
    Messages:
    1,647
    Likes Received:
    38
    Didn't think it would help fella but you could bet your last pound if i hadn't of mentioned it then it would of been that!

    Hope you get it sorted. :icon_thumright:
    #6
  7. MR ANGRY
    Online

    MR ANGRY Guest

    Have you tried clearing the fault code?
    Reason i ask is i too had a module done by them on a Golf mk5 last year.
    Plugged everything back in, & just like yours the light was still on.
    Took it to my pal who has a Snap On diagnostic, it was still showing that airbags had been deployed.
    Cleared those with his snap on gear & it was fine.
    #7
  8. Big Daz
    Offline

    Big Daz New Member

    Joined:
    Apr 30, 2010
    Messages:
    6
    Likes Received:
    0
    Yes mate had it on the snap-on and the launch. Its coming up with a code no one has heard of!?
    #8

Share This Page