1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

air flow meter problems.

Discussion in 'A4/S4 forum(B5 Chassis)' started by jbh, Oct 31, 2013.

  1. jbh
    Online

    jbh TDi lover

    Joined:
    Jan 3, 2010
    Messages:
    763
    Likes Received:
    84
    right ran a scan on the bus today and got the afm fault. so into the garage to get my spare... and the plug is different!!
    can i go to a breakers and just get a plug and wire it in and use the newer one or do i need to get the same AFM


    [​IMG]


    [​IMG]
    #1
  2. jbh
    Online

    jbh TDi lover

    Joined:
    Jan 3, 2010
    Messages:
    763
    Likes Received:
    84
    even though theres 6 pins on my old AFM there is only 5 wires in the plug.
    #2
  3. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,541
    Likes Received:
    303
    Unlikely, but get the part numbers and i'll check.

    I'd imagine they have different ECU's and the MAF's have different calibration.
    #3
  4. jbh
    Online

    jbh TDi lover

    Joined:
    Jan 3, 2010
    Messages:
    763
    Likes Received:
    84
    right im stumped.. I went down to my mates and got a shot of his AFM and put it on my car and got exactly the same. tried mine on his and it was fine. the code im getting is 00553 open / short circuit to earth so im starting to think its something on the car.
    so has any one got any pointers.
    #4
  5. Bradderz_1988
    Online

    Bradderz_1988 Dont replace it, Upgrade it !!

    Joined:
    Aug 19, 2010
    Messages:
    3,205
    Likes Received:
    105
    #5
  6. Bradderz_1988
    Online

    Bradderz_1988 Dont replace it, Upgrade it !!

    Joined:
    Aug 19, 2010
    Messages:
    3,205
    Likes Received:
    105
    ^^^ ignore that wrong fault code lol

    did you drive tge other car you tested it on or just run it and do a scan ??

    its possible that theres a wiring fault or bad connection !!
    #6
  7. jbh
    Online

    jbh TDi lover

    Joined:
    Jan 3, 2010
    Messages:
    763
    Likes Received:
    84
    yea we took the other car a run around the town and it was fine.
    im thinking its a wiring fault as you say. im just wondering if any one can point me in the right diurection on which pins at the ecu to test to see if and which wire is broken.
    #7
  8. jbh
    Online

    jbh TDi lover

    Joined:
    Jan 3, 2010
    Messages:
    763
    Likes Received:
    84
    Sorted I found a break in one of the wires and joined it and all is good again
    #8
    Bradderz_1988 likes this.
  9. jbh
    Online

    jbh TDi lover

    Joined:
    Jan 3, 2010
    Messages:
    763
    Likes Received:
    84
    im looking for a replacement plug for my MAF with as much wire as possible as the wires on my car dont look the greatest. there's also 2 wires that run to the plug on the N75 valve I would also like to replace these as they dont look to great.
    the break on my red/white ( pin 3 on the MAF plug ) wire was really close to the plug and to be honest the other wires dont look great at the plug end as well

    heres some info for future reference

    [​IMG]
    [​IMG]
    #9

Share This Page