1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Advice needed please - Audi A4 B5 Avant facelift model electrical issues

Discussion in 'A4/S4 forum(B5 Chassis)' started by oldbanger, Oct 5, 2012.

  1. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 5, 2012]
    Hello all. I have read endless amounts of threads on this and 2 other audi/vag forums. So please dont get stressed if I ask something that has already been covered, my search skills usually find the answer i need, unless of course it hasn't been covered before....

    I have a 99 A4 B5 Avant , recently bought it with a few problems which i really want to get sorted out.

    1- No keyless entry working
    2- No alarm working

    Here's a description of the car..

    -The car's 5 doors all lock and unlock as they should via the central locking system when the key is turned in driver's door

    -The central locking pump doesn't over-run ever. I here it for 5 seconds max when in use. (air-lines all good)

    -The alarm never goes off, the hazards never flash when locking the car, the siren is still connected in the boot and looks fine

    -No signs of water leakage in any foot wells, or the right-rear stow area which holds the central locking pump and alarm siren

    -The red security LED's on the driver and passenger doors never flash when the car is locked. The only time I have seen them light up is when i press the motion sensor kill switch on the 'b' pillar - this results in them lighting up for about 3 seconds steady, then turning off again

    -The 3-button switchblade key has been checked by a decent auto locksmith - he says the key is giving off a signal as it should.

    -The red puddle lights on both front doors function as they should when a door is opened.

    -Front, middle and boot section roof/interior lights function as they should - they turn on and off exactly as they should when doors are opened and closed.

    -Only the boot being opened gives an animation on the driver information module (red screen in dash). As this is the facelift model, im quite sure it should show animations for when any of the 5 doors are opened, not just the boot.

    -As soon as all doors are closed, and i lock the car with the key in the door, all lights immediately shut down as they should and i here (and check) all 5 doors lock as they should.


    Hopefully you guys can give me some useful information on this, id be greatful.

    Thanks guys

    Richard
    #1
  2. Ads

    Ads

    [Sep 22, 2014]

  3. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 5, 2012]
    ALSO!

    If i use vcds lite to so a scan , is there any precautions i need to take? By this i mean, is there a possibilty i could kill hte ecu, for instance if my laptop battery cut out whilst scanning? Any precautions to be taken would be greatfully received ;)
    #2
  4. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,578
    Likes Received:
    314
    [Oct 5, 2012]
    At the simplest it could be something like a broken bonnet switch and a unsynced remote. If bonnets open the alarm wont arm, hence no flashing lights and no indictor blink. Remote can get unsynced if the battery has been changed for instance.

    At worst it could be a faulty central locking pump.


    VCDS is your first step, and no, you cant break anything with it just scanning for codes. You should be able to view the measuring blocks, and see what the CL pump thinks of the status of each door.
    #3
  5. Bradderz_1988
    Offline

    Bradderz_1988 Dont replace it, Upgrade it !!

    Joined:
    Aug 19, 2010
    Messages:
    3,234
    Likes Received:
    106
    [Oct 5, 2012]
    Try recoding the ecu by using the info from ross-tech it may just need coding.

    Ross-Tech is not responsible for any damage or problems that may result from following these instructions. They are to be used at your own risk.


    Specific Modules:


    01-Engine: -- KWP-1281
    VCDS works well with all engines available in the U.S. and most engines that users have tested in overseas markets.


    Idle Speed Adaptation:


    With engine warmed up, at idle:


    [Select]
    [01 engine]
    [Adaptation - 10]
    Enter channel 01
    Enter an adaptation value between 124 and 132
    [Save]


    (May require a Login of 01283 or 11463, depending on year or model)


    Throttle Body Adaptation:


    Turn the key on but do not start the car.


    [Select]
    [01 - Engine]
    [Measuring Blocks - 08]
    Enter Group 060 (may be Group 098 on some cable-throttle cars)
    [Go!]
    [Switch to basic settings]


    Once you do this you will see the top right display say ADP RUN. The TB
    adaptation is being done as soon as you switch to basic settings. You will see the values change and hear the TB cycle for the first few seconds then it will stop. Leave it in basic mode for about 30 seconds, then switch back to normal settings and you're all set.


    Be sure not to touch the accelerator and make sure the engine is NOT running when you do this!


    02-Auto Trans : -- KWP-1281
    VCDS works fine


    Recoding Tiptronic:


    In the newer cars, there are coding options for "Old" vs "New" "Tiptronic strategy". The "New" stategy (introduced in 2000 I think) is much more "automatic" than the old. To get the "Old Tiptronic strategy" where it won't downshift unless you come to a complete stop, I believe you have to change the coding in the following manner:


    [Select]
    [02 - Auto Trans]
    [Recode - 07]
    Enter the coding below
    [Do It!]


    Write down the original coding for future reference.


    Look at the fourth digit in the coding (Cylinders):


    0 or 1 - "New-style Tiptronic"
    2 - "Old-style Tiptronic"


    Look at the fifth digit in the coding (Market version):


    1 - "Rest of world, quattro"
    2 - "USA, quattro"
    3 - "Rest of world, FronTrak"
    4 - "USA, FronTrak"


    So, for a USA model A4 quattro, if the original coding is 00002, and you want to change to the "Old-style Tiptronic" strategy, change the coding to 00022.


    PS: As always, you play with stuff like this at your own risk. The "old" strategy is documented by VW only for "testing" and they explictly say that the car should be recoded the way it was before giving it back to the customer.


    03-ABS Brakes: -- KWP-1281
    VCDS works fine


    08-HVAC: -- KWP-1281
    VCDS works fine


    15-Airbags: -- KWP-1281
    VCDS works fine


    17-Instruments: -- KWP-1281
    VCDS Works fine.


    Immobilizer Procedures in the Ross-Tech Wiki


    Note: US/Canada model Audi A4/S4 do not have Immobilizers.


    Recode for warning lamps (through 1999 only):


    [Select]
    [17 - Instruments]
    [Recode - 07]
    Write down the existing coding for future reference.
    Enter 5-digit code from below
    [Do It!]


    Look at the first two digits in the coding. Add the values for the options together to get the correct coding.


    00 - No available equipment
    +01 - Brakepad wear sensor warning active
    +02 - Seatbelt warning active
    +04 - Washer fluid level warning active (may only work with pre-2000 models)
    +16 - Navigation System (non-USA models)


    Look at the third digit in the coding (Market version):


    0 - "Germany" 24 hour clock
    1 - "Rest of World" 24 hour clock
    2 - "USA" 12 hour clock
    3 - "Canada" 12 hour clock


    Look at the fourth digit in the coding (Cylinders):


    4 - 4-cylinder
    6 - 6-cylinder


    Look at the fifth digit in the coding (Distance impulse multiplier):


    0 - TDI Engine (non-USA models)
    2 - Non-turbo Gasoline engine
    4 - Turbocharged engine


    So, if you want to have Seatbelt warning and washer fluid warning only in a 1999 Canadian A4 2.8, (add 00+02+04 = 06),3,6,2 = 06362.


    A complete instrument cluster coding chart which includes 2000 and newer cars is available in the Ross-Tech Wiki.


    Change Language Displayed:


    [Select]
    [17 - Instruments]
    [Adaptation - 10]
    Enter channel 04


    The available languages are :


    00001 - German
    00002 - English
    00003 - French
    00004 - Italian
    00005 - Spanish
    00006 - Portuguese


    [Save]


    Resetting Service Reminder Intervals:


    Ross-Tech: VAG-COM: Audi Service Interval Reminders


    22-AWD – Purely Mechanical!
    The quattro system in these cars is purely mechanical, no electronics at all. This address is used by the Haldex system used in transverse-engine cars like the TT, the A3, and various Golf/Bora models.


    35-Central Locks: -- KWP-1281
    VCDS Works fine (note: pre-'97 A4's may not have this module).


    Recode locking options


    [Select]
    [35 - Cent. Locks]
    [Recode - 07]
    Enter the coding below
    [Do It!]


    Write down the existing coding for future reference.


    A4 pre-1998 with Delta radio and anti-theft system
    Standard Coding: 03468


    A4 pre-1998 with Delta radio, anti-theft system and keyless entry
    Standard Coding: 12172


    A4 1998+ with Concert/Symphony radio and anti-theft system
    Standard Coding: 03340


    S4, A4 1998+ with Concert/Symphony radio, anti-theft system and keyless entry
    Standard Coding: 16140


    Add the following options to your coding number:


    +64 Windows up, sunroof close, and windows down with remote.
    -04 One touch unlock of all 4 doors and trunk
    -1024 Remove horn honk when arming
    +32 Auto lock/unlock of doors (Doors lock at 15 mph and unlock when key is removed)


    So, if you want to have a 1999 A4 with Concert radio and anti-theft system and keyless entry, and you want to add window control with the remote along with auto-lock, then:
    add 03340+64+32= 03436


    37-Navigation: -- KWP-1281
    VCDS Works fine.


    45-Int. Monitor: -- KWP-1281
    VCDS Works fine (note: This is tied in with 35-Central Locking so it may not work with pre-'97).


    Sensitivity Adjustment


    [Select]
    [45 - Int. Monitor]
    [Adaptation - 10]
    Enter channel 01
    Enter a value between 50-100 (it should be 100 by default) for the sensitivity of the ultra-sound sensors
    [Save]


    55-Headlight Range: KWP-1281
    VCDS Seems to work fine.
    Note this controller is only present on cars with Xenon headlights.


    56- Radio: – KWP-1281
    Please read the following pages pertaining to Audi Concert and Symphony Radios.
    #4
  6. olds_kool
    Offline

    olds_kool Active Member VCDS Map User

    Joined:
    Jul 21, 2007
    Messages:
    1,072
    Likes Received:
    4
    [Oct 6, 2012]
    First check pump part number should start 8do and end in e
    On a facelift the alarm should go off if you mechanically unlock the car so I suspect previous owner stuck any old pump in there
    #5
  7. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 8, 2012]
    thanks very much for your input guys. i have now got an ebay cable and vcds lite. did a scan and it doesnt really run for long, as its the freeware version. is there anythiong i can do directly to check the status of the security system and remote entry? i am just about learning the idea of coding... i.e take note of original number, and add/subtract functions by numbers.

    my c/l pump part number is 8D0 862 257E
    my siren is 8D0 951 605

    I have just read the owner's manual and indeed it should display when any of the 5 doors are open. However the car never detects any of the main 4 doors being opened, it only detects the boot. Any ideas guys?

    I would like it if someone could give me a few instructions i could use to try and get them red door led's flashing again, that would be a great start!

    Once again, thanks for your input
    Last edited: Oct 8, 2012
    #6
  8. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 9, 2012]
    An update....

    Today i have been manually checking all the controllers using vcds. it had 2 codes stored, which i could clear and they no longer show up (i havent actually drove the car since clearing them, so i guess they may pop up later?) .

    They are:
    01176 key signal too low-intermittent
    17978 engine start blocked by immobiliser - intermittent p1570 - -35-10

    I cleared them and did many more scans and they didnt show up again (yet)


    One thing that worries me is that when i try connecting to module 35- central locking, it says too many communication errors to continue! What does this mean guys??


    The only other thing i found, which i cleared is:
    01383 - alarm triggered by ANTI THEFT SENSOR FRONT RIGHT 35-00 on controller 45- internal monitor


    As stated previously, my alarm seems totally dead, i never have flashing door led's, and my remote entry doesnt work. I would love to get this problem sorted.

    Thankls for reading, and i hope you guys can help.
    #7
  9. olds_kool
    Offline

    olds_kool Active Member VCDS Map User

    Joined:
    Jul 21, 2007
    Messages:
    1,072
    Likes Received:
    4
    [Oct 9, 2012]
    Ok pumps correct
    As aragorn said you may just need to resync fob and get remote locking working (if you have two keys google it)
    And bonnet switch is most likely cause of alarm not setting
    I'd put money on your siren being dead anyway from battery leakage but indicators should still flash
    The door open indicator only works on later facelifts with digital clock only boot shows on earlier analogue clock clusters
    #8
  10. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,578
    Likes Received:
    314
    [Oct 9, 2012]
    Try unplugging the bonnet switch and see if it then arms. Mines unplugged as the switch is smashed and my alarm works fine.
    #9
  11. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 11, 2012]
    Thanks again guys for our help. i tried unplugging bonnet sensor, no difference...

    However I just managed to briefly connect to 35-Cent Locking by using KWP-1281, this helps with communication issues.

    Something i found was that my cv pump is coded with : 32767 isn't this for a passat????

    Also, the WSC (workshop code) is a 6 digit number, and vcds only accepts 5 digit numbers.....

    I tried to quickly change the cv pump code to 16140, and it didnt allow it as the WSC was over 6 digits long.

    I know even if the WSC was 5 digits i still probably wouldn't have been able to change anything, as the 'too many communication errors' message still pops up, but at least now i get to see a bit more data. Before I could only see the vag number and 'CV PUMP'.

    So please tell me, is 16140 the code I should have for alarm and keyless entry, and not 32767?


    I hoep its just a case of a wrtongly coded cv pump!!!
    #10
  12. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,578
    Likes Received:
    314
    [Oct 11, 2012]
    if its an ebay lead, open the device manager and go into advanced properties for the usb serial port, you'll find a setting for latency timer which by default is set to 16ms. try turning it down to say 4ms or 2 or 1 and see if that improves the comms errors.

    I'll check my coding for you in a bit.
    #11
  13. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 11, 2012]
    Already tried that. Also changed receive/transmit rates to a real low rate. This is so frustrating! Can any disconnection of other parts possibly help? I.e the siren or stereo??
    #12
  14. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 12, 2012]
    So what else could i do to get the cv pump to communicate better please?
    #13
  15. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 28, 2012]
    The poblem still exists! Using a better laptop and protocol kwp2000 i finally got a fault code scan of module 35-centrl locking done tonight. It came up with the following list. I reeatedly tried recoding it to 16140 but no joys! Is it because im using kwp2000? If i use kwp1281, the fault code san cannot complete, and i get the communication error message. Is it possible that the following fault code list has only been thrown up as the pump is coded with 32767 and not 16140?

    VCDS-Lite Version: Release 1.0
    Sunday, 28 October 2012, 17:51:37:0
    Control Module Part Number: 8
    Component and/or Version: CV-Pump D13
    Software Coding: 32767
    Work Shop Code: WSC 131071
    28 Faults Found:
    01367 - Central Locking Pump Run Time Exceeded (Likely Leak)
    35-00 - -
    01371 - Shareware Version. To Decode all DTCs
    35-00 - Please Register/Activate
    01372 - Shareware Version. To Decode all DTCs
    35-00 - Please Register/Activate
    01374 - Alarm triggered by Terminal 15
    35-00 - -
    01370 - Shareware Version. To Decode all DTCs
    35-00 - Please Register/Activate
    01369 - Shareware Version. To Decode all DTCs
    35-00 - Please Register/Activate
    01368 - Alarm triggered by Luggage Compartment Switch
    35-00 - -
    01373 - Shareware Version. To Decode all DTCs
    35-00 - Please Register/Activate
    01366 - Shareware Version. To Decode all DTCs
    35-00 - Please Register/Activate
    01361 - Switch for Anti-Theft Alarm; Close
    29-00 - Short to Ground
    01360 - Shareware Version. To Decode all DTCs
    29-00 - Please Register/Activate
    01362 - Shareware Version. To Decode all DTCs
    29-00 - Please Register/Activate
    01363 - Switch for Central Locking; Driver's Door (F59)
    27-00 - Implausible Signal
    01364 - Shareware Version. To Decode all DTCs
    27-00 - Please Register/Activate
    01365 - Shareware Version. To Decode all DTCs
    29-00 - Please Register/Activate
    01365 - Lock/Unlock Switch; Interior
    28-00 - Short to Plus
    01389 - Shareware Version. To Decode all DTCs
    29-00 - Please Register/Activate
    01571 - Shareware Version. To Decode all DTCs
    29-00 - Please Register/Activate
    00000 - End of Output
    00-00 - -
    00991 - Shareware Version. To Decode all DTCs
    28-00 - Please Register/Activate
    00955 - Shareware Version. To Decode all DTCs
    09-00 - Please Register/Activate
    00956 - Key 2
    09-00 - Adaptation Limit Surpassed
    00957 - Shareware Version. To Decode all DTCs
    09-00 - Please Register/Activate
    00958 - Shareware Version. To Decode all DTCs
    09-00 - Please Register/Activate
    01134 - Alarm Horn (H12)
    76-10 - Terminal 30 missing - Intermittent
    01134 - Shareware Version. To Decode all DTCs
    77-10 - Please Register/Activate - Intermittent
    01134 - Shareware Version. To Decode all DTCs
    49-10 - Please Register/Activate - Intermittent
    00000 - End of Output
    00-10 - - - Intermittent
    #14
  16. olds_kool
    Offline

    olds_kool Active Member VCDS Map User

    Joined:
    Jul 21, 2007
    Messages:
    1,072
    Likes Received:
    4
    [Oct 28, 2012]
    under component it should list the part number of the pump?
    you need to delete all those codes then read again but i suspect the pump is either knackered and needs replacing or its the wrong pump with a correct part number on the lid
    never seen that many codes before! but ive also never seen a factory pump coded 16140, 13130 is the usual coding

    the only reason for not accepting new coding is if it cant perform the function you try and code i.e if it isnt a remote capable pump then it wont accept coding for remote locking
    try coding a different function and see if it accepts it, for example add 32 for auto locking at 10mph
    #15
  17. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 28, 2012]
    ok thanks. the odd thing is - the central locking works perfect on the key when turned in the door. ie the drivers door only or all 5 doors on two twists of key. and the pump never runs for more than 5 seconds.

    but thanks, il try that tommorow. i was under the assumption that pretty much any 5 digit number could be entered, seeing as it had a totally wrong number and wsc number on it to start with !?
    #16
  18. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 28, 2012]
    where did you get 13130 from ?
    #17
  19. olds_kool
    Offline

    olds_kool Active Member VCDS Map User

    Joined:
    Jul 21, 2007
    Messages:
    1,072
    Likes Received:
    4
    [Oct 28, 2012]
    from refurbing about 60+ locking pumps
    just run 16140 through decoder and its 1 touch locking and honk on alarm settimg but no window control with remote
    your existing coding is 1 touch locking, auto locking at 10 mph, remote windows and honk on arm so that suggests its already coded for remote locking so im back to thinking its knackered
    #18
  20. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 28, 2012]
    sorry to be a pain but could you please send me a link to where you got the codes from?
    #19
  21. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 29, 2012]
    Hey olds_kool, it seems im getting the coding calculations totally wrong. On the ross tech wiki it says 1998+ with keyless entry, concert stereo etc is 16140. Could u please explain where 13130 comes from please? Sorry to be a pain
    #20
  22. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 31, 2012]
    Im guessing the pump is an incorrect pump, as you pointed out, or a faulty one.

    It cannot be recoded at all, won't accept 13130 or anything at all. Also the current coding is the maximum number/value tha vcds will allow to be entered (0-32767) and i suspect this is a sign of a fault.

    Wen i try to recode it (hit do it!) what happens is the part number appears as follows:

    8ÿ0 862 257 ÿ

    Whats with them strange 'y' characters? This is the only time it shows the part number, when it fails to recode the unit.

    I heard that 8D0 and 8L0 pumps are wired up differently. Is there a possibility my car might actually need an 8L0 pump ?
    #21
  23. olds_kool
    Offline

    olds_kool Active Member VCDS Map User

    Joined:
    Jul 21, 2007
    Messages:
    1,072
    Likes Received:
    4
    [Oct 31, 2012]
    correct pump its just knackered
    replace with correct 8D0 'E' or as an alternative you can fit an 8L0 'P' thats the only other pump compatable with the alarm siren (which i bet wont work anyway if its the original)
    #22
  24. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Oct 31, 2012]
    ok thanks very much for your advice . im off to get a replacement pump this weekend from a breakers. il write up the results.... fingers crossed!
    #23
  25. PAULF
    Offline

    PAULF Active Member

    Joined:
    Jan 27, 2011
    Messages:
    649
    Likes Received:
    50
    [Nov 1, 2012]
    I would also add in that Mrs PaulF has an early facelift Avant and she only has the boot light up - no doors - on the dash synoptic

    Avant DIS Door Warning Problem
    #24
  26. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Nov 7, 2012]
    Problem solved! Fitted a second hand pump and all is well - i finally have remote central locking! ! Vcds says no comms with siren but thats probably just the back up batteries have died- im not fussed about the alarm too much. The rest of the system shows no errors. Im guessing the previous pump was corrupt in terms of communication with the ecu. Thanks very much for your help
    #25
  27. macaroon
    Offline

    macaroon New Member

    Joined:
    Nov 15, 2012
    Messages:
    5
    Likes Received:
    0
    [Nov 15, 2012]
    oldbanger, i have same issue/problems as you had (led/alarm/indicators not flashing) and boot lid showing open on display when its clearly shut.
    Where is alarm horn located?
    Where do i start?
    #26
  28. NineNails
    Offline

    NineNails Proud sponsor of the snack food industry

    Joined:
    Sep 18, 2006
    Messages:
    583
    Likes Received:
    3
    [Nov 16, 2012]
    Start with the boot switch. Alarm won't arm if it thinks the boot is open
    #27
  29. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Nov 16, 2012]
    If only my problem was as simple as that! As nonenails says, get your boot sensor switch checked out. I bet that is the only problem. Your alarm siren batteries are probably dead too but that wont effect the arming of the system
    #28
  30. macaroon
    Offline

    macaroon New Member

    Joined:
    Nov 15, 2012
    Messages:
    5
    Likes Received:
    0
    [Nov 16, 2012]
    Thanks, i have changed the boot sensor. But to no avail, but i need LOCATE the alarm horn.
    #29
  31. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Nov 16, 2012]
    OOh! Im surprised the boot switch wasnt the fault. Im sorry but i only know the siren location on the avant (estate) model.
    #30
  32. oldbanger
    Offline

    oldbanger New Member

    Joined:
    Oct 5, 2012
    Messages:
    26
    Likes Received:
    0
    [Nov 16, 2012]
    Get the car plugged into vcds, download it free and get a cable off ebay for 15 quid
    #31

Share This Page