1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

advice needed on esp light then stalling

Discussion in 'A3/S3/Sportback (8P Chassis)' started by phil77, Sep 7, 2013.

  1. phil77
    Offline

    phil77 Member

    Joined:
    Jul 6, 2012
    Messages:
    56
    Likes Received:
    8
    [Sep 7, 2013]
    Hi all been searching for ages today and got a few ideas of what could be causing the fault codes i have, but just wanted to see if anyone had these same issues. So i can save time and money on replacing the right parts first time.

    my problems started when my esp light would show up and then on low idle the car would stall and also as soon as i turn the engine on the fan kicks straight on. These faults are intermittent.

    I have had it plugged in and these fault codes reoccur

    1. mass air flow circuit low input
    2. system too rich off idle bank 1
    3. system too rich off idle bank 2

    I am hoping someone has had the same issues and also is a cheap fix haha cheers all
    #1
  2. Ads

    Ads

    [Sep 20, 2014]

  3. sliced
    Offline

    sliced Drive safe, stay alive.

    Joined:
    Jun 12, 2012
    Messages:
    1,258
    Likes Received:
    260
    [Sep 7, 2013]
    What car is it? Age and engine specifics?
    #2
  4. phil77
    Offline

    phil77 Member

    Joined:
    Jul 6, 2012
    Messages:
    56
    Likes Received:
    8
    [Sep 7, 2013]
    my bad haha 8p 2004 3.2
    #3
    sliced likes this.
  5. Chillout
    Offline

    Chillout Active Member

    Joined:
    Apr 4, 2013
    Messages:
    596
    Likes Received:
    48
    [Sep 7, 2013]
    Is it serviced air filter especially and is the throttle body clean and is the battery good.
    sounds a bit like a dodgy maf I would try and disconnect it to see if it runs better.
    #4
  6. phil77
    Offline

    phil77 Member

    Joined:
    Jul 6, 2012
    Messages:
    56
    Likes Received:
    8
    [Sep 7, 2013]
    air filter was recently changed on a service and throttle bodys clean. it wasn't a new one but a different maf was put on and the problem continued
    #5
  7. Chillout
    Offline

    Chillout Active Member

    Joined:
    Apr 4, 2013
    Messages:
    596
    Likes Received:
    48
    [Sep 7, 2013]
    Does it do it with the maf disconnected your esp light comes on when you disconnect the maf if it wasn't lit before and is your carbon canister clear can you blow through it .

    i kinda think your cts is faulty and maybe would explain your fans and maybe the over fuelling as its possible the ecu doesn't have an accurate reading to regulate fuel trims properly.

    stab in the dark though I would run graphs on vcds
    Last edited: Sep 7, 2013
    #6
  8. phil77
    Offline

    phil77 Member

    Joined:
    Jul 6, 2012
    Messages:
    56
    Likes Received:
    8
    [Sep 7, 2013]
    i haven't ran it disconnected and currently not with the car till next week but will try it then. will also get them to run graphs see what shows up. many thanks chillout
    #7
  9. phil77
    Offline

    phil77 Member

    Joined:
    Jul 6, 2012
    Messages:
    56
    Likes Received:
    8
    [Sep 8, 2013]
    mate sent me this morning so gonna start changing parts. start with temp sender

    [​IMG]
    #8
  10. Chillout
    Offline

    Chillout Active Member

    Joined:
    Apr 4, 2013
    Messages:
    596
    Likes Received:
    48
    [Sep 8, 2013]
    Maybe it was a good guess then I would also check your earth points behind the headlights especially
    #9

Share This Page