1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Advice need please

Discussion in 'A4/S4 forum(B5 Chassis)' started by dentsy, Aug 23, 2010.

  1. dentsy
    Offline

    dentsy I HAVE THE OPTION CODES

    Joined:
    May 20, 2007
    Messages:
    249
    Likes Received:
    15
    Hi All,

    Sorry if I am posting this in the wrong section.

    I ahve a 1995 N Reg 1.8 20V A4 Saloon I ahve a couple of problems that I need answers too please if someone can help.

    1/ When starting the car sometimnes she will keep cutting out the guy that I bought it off said it was an immobiliser issue and said that if I opened the door and shut it agin The car would start I have tried this a few times but this seems to make no difference. If I try to start it one day & it cuts out I keep trying and after about 4 or 5 attempts she will go.

    She does actually fire up & run but then immediatly cuts out.

    Sometimes I can go a week without this happening anyone got any ideas please ?

    Also I have a cheap cd head unit in it that I am looking to change doea nyone know if I want an Audi one that if its the concert head unit that I need ?

    If so does anyone have one for sale,

    Regards,

    Simon

    p.s if anyone needs the Audi option codes tool I have it :)
    #1
  2. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator

    Joined:
    Jan 30, 2008
    Messages:
    15,529
    Likes Received:
    301
    Concert wasnt fitted as early as 95 afaik, and its a pile of **** anyway so i wouldnt bother.

    Sounds like the immo, theres a light on the dash with a symbol, if you flip the ignition on and watch it, you should see it go out after 2-3seconds. When it doesnt start it probably starts flashing. You can try waiting for the light to go out before starting the car (might need to turn the ignition on and off a few times)

    You'll need vagcom to work out whats going on, but its likely that the reader coil is getting a bit dodgy.
    #2
  3. 27litres
    Offline

    27litres Love My Quattro

    Joined:
    Jun 7, 2010
    Messages:
    20
    Likes Received:
    0
    The immobiliser is a really common fault on the B5's. In fact I'm surprised more people aren't in the know about fixing it! If you go to Audi, a VAGCOM will show it as a faulty immobiliser or coil, and they'll charge you about $1000 ( [FONT=Times New Roman, serif]£[/FONT]500)to fix it (because they replace it), and that may be the problem, too many VAGCOM's and not enough troubleshooting!

    Anyway, fixing it it really simple:
    First, remove the lower dash panel (between steering wheel and foot pedals), it's held on by about 4 8mm headed bolts, no tricks...
    Then locate the little cream/white box just above where your right knee would be when sitting normally. There should be a wiring plug on the right side near the back.
    The quick fix is to unplug and plug in a few times to fix any connection problem.
    The more permanent fix is to get a little bit of electrical contact spray (I actually used Inox, as it won't harm the plastic), spray both sides of the electrical connection and plug back in.
    Reassemble the lower dash panel and you're done!

    For good measure, you can remove the steering column lower panel too, and do the same job to the small 2-wire plug on the energiser coil (black plastic ring around the ignition barrel) - just to be sure.

    The problem that causes the erratic immobiliser is actually one of corrosion inhibiting the electrical connection, because the wiring loom plug and the connector on the immobiliser box are made of different metals and react to each other over time. The contact spray (or Inox) helps to inhibit this reaction, mainly by preventing oxygen (which is the catalyst) getting to the contact point.
    #3
  4. dentsy
    Offline

    dentsy I HAVE THE OPTION CODES

    Joined:
    May 20, 2007
    Messages:
    249
    Likes Received:
    15
    Wow thanks guys for the fast replies I really appreciate it I will try the fix on my next days off and will let you know how I get on. With regards to the head unit which cd was fitted to the early B5's then as I really would like an Audi
    unit in it.

    Thanks

    Simon :)
    #4
  5. 27litres
    Offline

    27litres Love My Quattro

    Joined:
    Jun 7, 2010
    Messages:
    20
    Likes Received:
    0
    I doubt any CD head units were included in B5's until the 99.5 update, and by then they would have been double DIN.
    I'm not sure of the specs on the Concert and Symphony units - they're the ones that are extra wide and take up the space by those blanks you've probably got in your dash. There's probably a sub forum on those, if not try Quattroworld or Audizine.
    Early ones did come with stackers in the boot (mine did). I've since chucked it in favour of Clarion and can't remember the brand -I do remember being underwhelmed by it, so I think it was Eurovox or something equally ****!
    #5
  6. dentsy
    Offline

    dentsy I HAVE THE OPTION CODES

    Joined:
    May 20, 2007
    Messages:
    249
    Likes Received:
    15

    Well Guess what ?

    I tried this Immobiliser fix & its been perfect now for 3 Days :)

    Your a Diamond mate saved me a fortune & a lot of swearing has stopped

    many Thanks Indeed

    Regards,

    Simon
    #6
  7. 27litres
    Offline

    27litres Love My Quattro

    Joined:
    Jun 7, 2010
    Messages:
    20
    Likes Received:
    0
    No wories mate!

    Like I said, I'm surprised this fix isn't better known! Though I think US spec cars didn't necessarily have the immobilser function active, so they probably don't get the issue...
    #7

Share This Page