1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ABS sensor removal

Discussion in 'A4/S4 forum(B5 Chassis)' started by Griffter, Sep 27, 2006.

  1. Griffter
    Offline

    Griffter New Member

    Joined:
    Jan 3, 2006
    Messages:
    19
    Likes Received:
    0
    [Sep 27, 2006]
    Following on from my previous post, I'd like to clean the ABS sensors and check the air gap to the toothed reluctor ring.
    How do I remove the ABS sensors? They seem intergral with the hub carrier! Can I get to the toothed reluctor ring without removing the driveshaft?

    Thanks.
    #1
  2. Ads

    Ads

    [Nov 26, 2014]

  3. QuantumJohn
    Offline

    QuantumJohn Member

    Joined:
    Nov 23, 2004
    Messages:
    142
    Likes Received:
    0
    [Sep 28, 2006]
    Later cars (facelift onwards) had small allen key bolts holding the rear ones in. Otherwise the rest need pulling out. Gentle tapping with a small hammer or leverage with a flat blade screw driver sometimes helps but be careful because it is easy to break them.

    They are £119 each new.

    John
    #2
  4. Griffter
    Offline

    Griffter New Member

    Joined:
    Jan 3, 2006
    Messages:
    19
    Likes Received:
    0
    [Sep 29, 2006]
    Ouch!

    Thanks John. the car's been used extensively over winter in Europe and I'm discovering that nothing comes undone/off/out with ease. I'll expect a struggle then...
    #3
  5. tracer
    Offline

    tracer '96 a4 1.8 se

    Joined:
    Oct 1, 2005
    Messages:
    266
    Likes Received:
    1
    [Sep 29, 2006]
    i have a similar problem at the moment but not just when turning left. managed to get all sensors out bar one which would not budge, had to mangle it a bit to get it out but i had already bought a new one from a guy on ebay.de for 68 quid including postage.

    this is what mine looked like

    [​IMG]

    i believe this is the other type mentioned by quantumjohn

    [​IMG]

    sensor in place................

    [​IMG]

    ..........cover removed

    [​IMG]

    i used lots of release oil like wd40 or dpr or something, then held a big blade screwdriver as shown to apply a bit of pressure on it , not too much, then wiggle the sensor by hand, even just back and forth - side to side and it will come free. this only worked for me on 3 out of 4 so maybe there is a better way.

    [​IMG]

    after getting all four out and cleaning both the sensors and the surrounding area, the problem disappeared. unfortunately it came back after two days. have since asked an audi technician and he reckons it could be a wheel bearing at fault and it is affecting the gap of the sensor, this could be true as in the past i have had a very slight noise at around 50mph , but now seems noticable at other speeds. should be able to just push the sensor back in and it will be ok again, but of course this is not a permanent fix.

    want to do the bearing myself, just have to pick my time to do it.
    #4
  6. Griffter
    Offline

    Griffter New Member

    Joined:
    Jan 3, 2006
    Messages:
    19
    Likes Received:
    0
    [Sep 30, 2006]
    Excellent info - thanks very much. I'll have a go tomorrow. If the problem still occurs with the sensors clean, I'd suspect the toothed ring. On another car I had the ring cracked and so was a 'C' shape as opposed to 'O' shape. The gap caused the ABS to kick in at low speeds. Can be fixed by epoxying the ring to the CV joint casing, holding in place with a Jubilee clip while drying - but of course on the A4 you have to remove the driveshaft to gain access...
    #5
  7. Jbone664
    Offline

    Jbone664 Oi Kent!

    Joined:
    Aug 25, 2006
    Messages:
    21
    Likes Received:
    0
    [Oct 1, 2006]
    great info.. I was wondering on how to get those suckers out! I need to clean mine. got a faulty wheel sensor so hopefully a clean will fix it... don't wanna have to buy another one..:ermm:
    #6
  8. NineNails
    Offline

    NineNails Proud sponsor of the snack food industry

    Joined:
    Sep 18, 2006
    Messages:
    583
    Likes Received:
    3
    [Mar 31, 2007]
    Hi. Sorry for digging up this old thread (at least I went and looked) but...I've got a rear sensor to replace in the next few days and was wondering...
    Is this the best method for removal? & is it easy to fit a new one?
    Cheers
    Si.
    #7
  9. NineNails
    Offline

    NineNails Proud sponsor of the snack food industry

    Joined:
    Sep 18, 2006
    Messages:
    583
    Likes Received:
    3
    [Apr 2, 2007]
    O.k, well, to answer my own question...NOT EASY AT ALL!!
    Peeled back boot, gave it a good soaking with WD40 24hrs before. Tried wiggling by hand, no chance, tapped it about a bit with a hammer, no chance, Metod mentioned above, no chance, Moderate twisting with mole grips, no chance. Lots of force with mole grips resulting in sensor coming apart. Now left with the outer shell well and truly jammed in its hole:crying:
    Garage job now I think.
    Every bloody job I try and do on this car ends in tears.
    Si.
    #8

Share This Page