1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ABS light

Discussion in 'A4/S4 forum(B5 Chassis)' started by Soupie69uk, Jan 20, 2011.

  1. Soupie69uk
    Offline

    Soupie69uk Owner

    Joined:
    Mar 10, 2004
    Messages:
    2,803
    Likes Received:
    7
    [Jan 20, 2011]
    Hi guys, recently my ABS light came on with 3 bleeps and both the lights came on on the clocks and on the DIS.
    I need to get this fixed for my MOT which is tomorrow but I cvan retest in a week or something I think for free.

    I took my car to a mates garage today and he has a snap on code reader. It could read the engine and electrics all fine but could not connect to the brake unit.

    Do you think the abs unit could have packed in? I thought the probolem would have been a sensor or a dodgy/dirty abs ring but since this code reader could not connect to the abs unit I am thinking it could be that.


    Any thoughts would be very much appreciated..........
    #1
  2. Ads

    Ads

    [Dec 18, 2014]

  3. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,845
    Likes Received:
    350
    [Jan 20, 2011]
    Its quite a common fault, and yes, if it beeps as soon as you power the ignition on, its likely the ECU. Especially as the code reader wouldnt connect to it.

    If it was a sensor or similar it would only beep after you drove off.
    #2
  4. Soupie69uk
    Offline

    Soupie69uk Owner

    Joined:
    Mar 10, 2004
    Messages:
    2,803
    Likes Received:
    7
    [Jan 20, 2011]
    Cool, that makes sense. It did about three weeks ago only come on occasionally like when I drove from Edinburgh to Leeds in all the snow it came on for around 15 mins near Newcastle but over the past week it will come on as soon as I turn the ignition on or after I have driven for a few meters.

    Where is the unit located and is it easy to replace?

    Oh and any ideas on how much they cost?

    Thank you for your help.
    #3
  5. jonnycraig
    Offline

    jonnycraig Member

    Joined:
    Jun 27, 2009
    Messages:
    157
    Likes Received:
    0
    [Jan 20, 2011]
    Same thing happened to mine, I ended up selling my quattro a week before its MOT as couldnt afford to fix it...gutted anyways have a look at this link it explains how to get it off for repair.

    AudiWorld Tech Articles
    #4
  6. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Jan 20, 2011]
    Same thing happened to me, had it repaired for £180. It's very easy to remove/refit using the instructions above.
    #5
  7. neilA4
    Offline

    neilA4 Member

    Joined:
    Aug 8, 2009
    Messages:
    190
    Likes Received:
    0
    [Jan 20, 2011]
    #6
  8. Soupie69uk
    Offline

    Soupie69uk Owner

    Joined:
    Mar 10, 2004
    Messages:
    2,803
    Likes Received:
    7
    [Jan 20, 2011]
    Cool, thanks for all the info.

    Has anyone used these guys on ebay?
    #7
  9. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Jan 20, 2011]
    BBA are the guys everyone uses and that's a really good price
    #8
  10. Soupie69uk
    Offline

    Soupie69uk Owner

    Joined:
    Mar 10, 2004
    Messages:
    2,803
    Likes Received:
    7
    [Jan 22, 2011]
    Thanks for the info folks. Took the controller off yesterday and BBA have arranged for it to be collected on Monday so hopefully this will sort my light. Car had the MOT and everything was fine other than the ABS light.

    Will update once I get the ABS controller back fitted next weekend.
    #9
  11. pjw
    Offline

    pjw Member

    Joined:
    Nov 20, 2010
    Messages:
    203
    Likes Received:
    0
    [Jan 22, 2011]
    I think this is dependent on which ABS it is perhaps, 5.3 or the earlier 5.0. Mine will beep if its got a code uncleared in the system, regardless if the problem has been physically fixed. Im Bosch 5.0.

    If you had cleared it certainly, then it went off when driving, mine is the same. But it will then bleep on startup every time afterwards.
    #10
  12. neilA4
    Offline

    neilA4 Member

    Joined:
    Aug 8, 2009
    Messages:
    190
    Likes Received:
    0
    [Jan 25, 2011]
    my spare abs ecu is being collected tomorrow, £90 for collection, fix and delivery not bad from bba on ebay. I spent £50 on a 2nd hand unit a few months ago didn't last long!
    #11
  13. jonnycraig
    Offline

    jonnycraig Member

    Joined:
    Jun 27, 2009
    Messages:
    157
    Likes Received:
    0
    [Jan 25, 2011]
    Wish I'd known it wasnt so expensive, I might still be drivin the Quattro now grrr!!! Awh well my new wagon arrives tomoro :)
    #12
  14. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,845
    Likes Received:
    350
    [Jan 25, 2011]
    u sold it because of an ABS fault?!

    PJW: thats interesting, but sounds likely. When we had a reluctor fault on the Quattro, it just put the small light on in the dash, no beep and no big flashing warning. Similar fault on the old '96 FWD set off the three beeps as you say.
    #13
  15. jonnycraig
    Offline

    jonnycraig Member

    Joined:
    Jun 27, 2009
    Messages:
    157
    Likes Received:
    0
    [Jan 25, 2011]
    Unfortunately yip :/ it was a few days before the MOT and didnt have the money to start replacing bits n pieces awh well live'n'learn. There were a few other things wrong too but nothing serious. Anyway new one tomorrow!
    #14
  16. Soupie69uk
    Offline

    Soupie69uk Owner

    Joined:
    Mar 10, 2004
    Messages:
    2,803
    Likes Received:
    7
    [Jan 29, 2011]
    Well folks the ABS issue is now resolved. I paid BBA £100 through ebay as that way I got free postage and UPS collected the unit on Monday and it was back to me on Thursday. I fitted it cleared any codes and everything was fine when I scanned the car again after a run....happy days.

    BBA also called me on Wednesday morning to tell me that they had found a fault and it had been repaired so all in all I am very impressed with their service.
    #15

Share This Page