1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Abs and traction control warning light

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Wels1, Oct 9, 2013.

  1. Wels1

    Wels1 New Member

    Joined:
    Jul 31, 2013
    Messages:
    2
    Likes Received:
    0
    Hi,
    I have a 2004 Audi A3 and my Abs and Traction control light come on after around 40mph and stay on until i turn the ignition off, anyone had this problem and possible causes? Also how I can fix this problem? Thanks
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. T33_BKD

    T33_BKD Cruiser

    Joined:
    Apr 10, 2013
    Messages:
    74
    Likes Received:
    6
    Hi, I currently have this on my 06 2.0tdi, a scan shows that it's the rear right abs sensor/wheel bearing. After reading a few threads on here suggests that replacing the wheel bearing fixes this(common fault) . Perhaps a scan will give you more info. I'm Looking to get the wheel bearing replaced soon, but not in any rush as it's not really causing any other problems.
     
  4. J8TT X

    J8TT X Member

    Joined:
    Jan 2, 2011
    Messages:
    357
    Likes Received:
    9
    I had this the other day, it came on and off for 2 days and now has gone.
    You need to get it scanned and it will tell you what's wrong.
     
  5. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat
    Site Sponsor Gold Supporter VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    28,332
    Likes Received:
    1,462
    As already advised, it needs a scan tbh as there are various possible reasons for this, from steering rack, to abs sensors, bearings, steering angle sensor etc.
     
  6. CraigWonn8P

    CraigWonn8P New Member

    Joined:
    Mar 18, 2013
    Messages:
    15
    Likes Received:
    0
    I have the exact same problem at the moment. Nightmare as I'm looking to sell up soon.
     
  7. jayjay11

    jayjay11 New Member

    Joined:
    May 17, 2009
    Messages:
    6
    Likes Received:
    0
    Same thing happened on my 55 TDI It needed a new abs unit there is an electronic part that is failing common I was told got a refurb part x unit all fitted by my local independent garage for £120.00
     

Share This Page