1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ABS and ESP lights on the dash all the time

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by vrbob, Mar 24, 2010.

  1. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Hi,

    Just went to drive to work (have not made it yet). Started the car as normal all lights off on the dash, put my foot on the brake selected drive and took my foot off the brake pedal and as soon as i did that the ABS and ESP lights came on and wouldnt go away. I stopped turned off and tried again same thing. Tried once more and noticed that the lights stay off until i release the brake pedal to move off and then they come on.

    Dont have access to VAGcom at the mo so any ideas as to what might be up and is there anything i can do for now or do i have to get it to the garage for a professional to sort it?

    Cheers
    #1
  2. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Just been out looking at the car and discovered that the brake lights dont work at all (lucky i didnt hit the motorway me thinks).

    From what i can gather for here and google is that it looks like the cause might be a faulty brake switch. Any ideas as to where i find this switch and can i replace it myself?

    "edit" just found this thread http://www.audi-sport.net/vb/showth...d-ESP-lights-Brake-pressure-sensor-fault-Help!

    Been to Audi got a new switch and all looks like its gonna be ok so now off to work only 2 hours late so far
    Last edited: Mar 24, 2010
    #2
  3. 1wheelonly
    Offline

    1wheelonly cabriolet

    Joined:
    Oct 14, 2007
    Messages:
    2,060
    Likes Received:
    4
    common fault bob, its at the top of your brake pedal mate, its like a plunger
    #3
  4. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Cheers 1wheel,

    Yeah looks like the new switch fixed it, Was a tad worried when i showed up at Audi and the guy on the parts desk handed me the new switch as it was totally different but he assured me it was a revised model. It fitted ok (i made sure i put it in the right way by using the old one first) then plugged in the connector started car and hey presto i now have brake lights again and no warnings on the dash.

    Gotta admit it feels much better to solve something myself and anly pay £10 to get it sorted.

    Off to work now
    #4
  5. tommac
    Offline

    tommac New Member

    Joined:
    Mar 19, 2007
    Messages:
    19
    Likes Received:
    0
    good work- always nice when you can fix things yourself!
    #5
  6. 1wheelonly
    Offline

    1wheelonly cabriolet

    Joined:
    Oct 14, 2007
    Messages:
    2,060
    Likes Received:
    4
    ^^^^^^^^^^^^^^^ agreed ! ironicly i only did one yesterday for a mate on his mk4 golf, seems to be very common across the vag group
    #6
  7. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Well can confirm all is good now at work and making the most of it by posting on here

    Weird never heard of it before but then im not as clued in as some of you guys.

    I hope the revised style switch is more reliable but i suppose the other one lasted 6 years and 100,000 miles before breaking so not too bad.
    #7
  8. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,885
    Likes Received:
    475
    I'm about 7 hours too late for posting the "How To" guide then ....... lol

    Glad it's sorted, everyone loves an easy fix :icon_thumright:
    #8
  9. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Yeah James where were you at 8am this morning when i needed you!

    Found that guide i the A6 section and then was just a case of getting my fat ass upside down in the drivers footwell to get the switch out and put the new one in.

    If only all Audi probs were as easy and cost effective to fix :crying:
    #9
  10. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,885
    Likes Received:
    475
    I've been off all week, and you chose today to breakdown?! ;)
    #10
  11. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Hey i didnt choose anything its down to the car whether it wants to play ball or not!

    Quick other question though : every so often when i start the car it flashes a brake warning in the DIS screen and beeps at me and then goes away, it only does it like once in every to starts any ideas?
    #11
  12. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,885
    Likes Received:
    475
    Battery mate, I'm pretty sure. I think it's when the current draws down quite low, since I replaced my battery it hasn't done it once!
    #12
  13. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Gave the battery a good charge the other night and it didnt take to much to top it up. How can you tell if its on its way out? as i have looked on ebay and you can get a Varta battery for under £100 delivered, but obviously i dont wanna have to buy it if i dont have to.
    #13
  14. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Gave in and bought a new Bosch HSB096 battery with a5 year warranty.

    Hopefully that will stop the flasing brake warning happening.
    #14
  15. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,885
    Likes Received:
    475
    I'll be interested to see what effect it has on your starting issues too.
    #15
  16. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Wont get to test the starting issues till mondays drive to work, as its always the afternoon start after the car has sat in the car park for the day that is the worst to do.

    Am hoping the battery will at least help (it cant make it any worse) still erring on some king of fueling issue though as i think you do to. Just had a message that says my VAGcom cable should be here by friday next week so will have a play and see if i can get some scans done to aid in the diagnosis.

    There must be another temp sensor on the car other than the thermostat (my car happily sits at 90 no probs) where it thinks the cars engine is colder than it is and is chucking too much diesel into the engine when starting ans sort of flooding it so it cant start properly.

    But i am only guessing really
    #16
  17. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    For the first time since i got the car it started fine after work.

    I noticed the glowplug light stayed on longer when i turned on the ignition and it fired up almost straight away with no smoke. So it has to be a temp issue with my car thinking its warmer than it actually is and not letting the glowplugs heat the diesel enough before starting. Its only a guess and i will have to do a few more tests to see if it continues to start better or if this was just a once off.
    #17
  18. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,885
    Likes Received:
    475
    Was it still starting badly with the new battery until today?
    #18
  19. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    yup the new battery hadnt helped with the starting issue till yesterday when it started ok.

    The car was an ice cube this morning and the DIS said it was 0 degrees outside and the car started almost straight away (after the glow plug light turned off). So will see how it does when i go home today but fingers crossed its ok again will keep my eye on the glow plug light to see how long it stays on as it does seem to be related to how the car starts.
    #19
  20. BlackQuat
    Offline

    BlackQuat Active Member

    Joined:
    Nov 24, 2009
    Messages:
    1,790
    Likes Received:
    43
    Going well then bud? You got round to doing the dis/cruise yet?
    #20
  21. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    No Vagcom cable yet and does not look like it will arrive till after i have left on Sun for a holiday so will have to do it when i get back. Got the coding page you linked to on the other thread so i think i am well prepared now for the fit what with the pics you took and everything.
    Last edited: Apr 1, 2010
    #21
  22. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Well started ok again today after work not imediate but alot quicker than it has been plus my white smoke screen has been reduced to a small cloud so things defo seem to of improved.
    #22
  23. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,885
    Likes Received:
    475
    Its probably just starting better as the air temp is colder do you think?
    #23
  24. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Could be, i have booked the car in for a full service next week so will see if that helps at all too.
    #24
  25. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    Back from holiday and the car has had its full service, (although would of helped if i had checked the MOT as it ran out today doh! so getting that done next week)

    They mechanic said no faults they could see in regard to my starting issue and they thought it was probably down to the fuel pump timing. So i am gonna drive it this week and see how it goes and then if its still playing me up i will get them to look at the timing and see if it needs adjusting.

    I have also scanned the car with my new VCDS cable and didnt get any faults for the engine or sensors so thats good but doesnt help with the starting issue as such.
    #25
  26. vrbob
    Offline

    vrbob Thats no Moon, Thats a space station!

    Joined:
    Jun 19, 2007
    Messages:
    2,364
    Likes Received:
    157
    *Bump*

    Right got a few more symptoms in regards to my starting issue so :

    The car starts well 90% of the time it just seems to have issues when i go to start it after i finish work (so after it has been standing around for 8 hours after a 40 min journey in the morning). The thing i have noticed is that the starting problem seem to relate to the glowplug light on my dashboard. By this i mean if when i turn on the ignition the glowplug light comes on (to indicate it warming up the plugs), if the light stays on for more than 1 sec the car starts ok (it has done this a few times but not very often), if the glowplug light litrally flashes on then off it takes 2 attempts to get the car to start and i have to keep the starter motor going for a good 3-4 secs and it also kicks out a cloud of white smoke.

    After i have driven the car and its warmed up i can turn it off go away and come back say an hour later and it will start on the button even if the glowplug light just flashes on then off.

    So my question is why? any ideas will be greatly appreciated :)
    #26
  27. zapata123
    Offline

    zapata123 New Member

    Joined:
    May 21, 2010
    Messages:
    1
    Likes Received:
    0
    From the day in which ABS and ESP lights came on, remain always on (of course while starting switch is on). I passed the VAG-COM with the following:

    ABS-ESP front

    01542 Yaw Rate Sensor (G202)
    48.00 Suply Voltage.

    Can be the cause a faulty brake switch?. Anyone has had the same problem?.

    Thanks.


    Audi A4 2.5 TDI Multitronic 2003.
    #27

Share This Page