1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A6 Low rpm Tps???

Sammy~D Mar 7, 2013

  1. Sammy~D

    Sammy~D New Member

    3
    0
    1
    I have a 99 A6 2.8 30v 220k AT Quattro.

    I started the car yesterday and it would not stay running until I tapped the gas peddle and feathered it, then it would idle at about 250-300 rpm. No power under acceleration, and will not go over 30 mph.

    I ran the codes and it came up with 3;

    1. Throttle position Sensor
    2. o2 bank 1
    3. o2 bank 2

    I understand that the TPS is not replaceable, that you are just better of buying a used throttle body. But a lot of the time it can be some other outlying problem.

    I do not have a vagcom available to me at this point in time either.

    Any input will be helpful



    Sammy~D
     
  2. Chrisw4266

    Chrisw4266 Member

    50
    2
    8
    You could try cleaning the throttle body? Do you know which tps sensor as there's also one at the pedal end I think if your on drive by wire.
     
  3. Sammy~D

    Sammy~D New Member

    3
    0
    1
    I am going to try cleaning it but i heard it is a low success rate on doing that. And i do not know what one it just told me tps on my obd scanner. I honesty did not know their was one on the floor
     
  4. Chrisw4266

    Chrisw4266 Member

    50
    2
    8
    If your on DBW throttle there will be a TPS at the pedal end as well as throttle body. I'm pretty sure of it someone with a bit more knowledge will be able to confirm for you.
     
  5. Sammy~D

    Sammy~D New Member

    3
    0
    1
    I will look in to that. And see what i can find also just picked up a disassembled full engine and harness for $50 so i cam try the new tb on it. Keep any kind of info coming if you can or ideas to look into im all ears. Thanks
     

Share This Page