1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A6 2.5 tdi avant Quattro c5 water temp

Keggers Nov 25, 2012

  1. Keggers

    Keggers Member

    74
    2
    8
    The temperature gauge for my engine coolant has mostly stopped working then all of a sudden it starts to work again!! The car heater system is working normally when the gauge hasn't moved a smidge! Is there a sensor that might be at fault or is it a bigger job? Any advice appreciated, thanks
     
  2. mrnice

    mrnice Member

    156
    14
    18
    Temp guage sensor perhaps?, vcds scan might give a clue
     
  3. Keggers

    Keggers Member

    74
    2
    8
    Can anyone advise me of the location of the sensor for the coolant?
     
  4. mrnice

    mrnice Member

    156
    14
    18
    Sorry wish I could but mines a 4-pot, hopefully a 2.5 owner will be along soon
     
  5. adamss24

    adamss24 Well-Known Member

    4,500
    379
    83
    Take the engine cover off and look to the left of the injector pump- it's the sensor plugged in the black coolant pipe. Replace the seal with the new sensor and be careful with the plastic retaining clip- they do snap !
     
  6. Keggers

    Keggers Member

    74
    2
    8

    thanks adamss24, i'll look tomorow when i have some light, is it an expensive part and where would i be best to get the required sensor and seal? thanks again.
     
  7. adamss24

    adamss24 Well-Known Member

    4,500
    379
    83
    I would get one from dealer, the cheap ones don't last !
     

Share This Page