1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A6 2.4 Keeps stalling

Discussion in 'General Technical / How To' started by Petem, Sep 8, 2008.

  1. Petem
    Offline

    Petem New Member

    Joined:
    Sep 8, 2008
    Messages:
    4
    Likes Received:
    0
    [Sep 8, 2008]
    I just got the A6, my girlfriends brother owned it and had not driven it in about a year.

    It keeps stalling at low revs like under 1k.

    I have an autospark looking at it at the moment and he cant seem to figure out whats wrong, he suggests that the throttle body may need replaced.

    what do yuo guys think?
    #1
  2. Ads

    Ads

    [Dec 21, 2014]

  3. Oranoco
    Offline

    Oranoco Well-Known Member

    Joined:
    Jul 27, 2007
    Messages:
    3,266
    Likes Received:
    222
    [Sep 8, 2008]
    Do the revs dip down and then rise back to normal tickover?

    If so whip the filter out and give the MAF sensor a good going over with an electrical contact cleaner aerosol. Leave it to dry out fully before running the car again. You may fins this cures the problem as it did on my old A4
    #2
  4. Petem
    Offline

    Petem New Member

    Joined:
    Sep 8, 2008
    Messages:
    4
    Likes Received:
    0
    [Sep 8, 2008]
    naw it stalls completely at low revs

    so driving along and go to turn round a corner put the clutch in to change gear slow down and it stalls, steering wheel locks...... disaster!
    #3
  5. Petem
    Offline

    Petem New Member

    Joined:
    Sep 8, 2008
    Messages:
    4
    Likes Received:
    0
    [Sep 15, 2008]
    Bump!

    It may be the throttle body, but what would go wrong with it to mean that it keeps stalling a low revs in first gear?
    #4
  6. S3 Jock
    Offline

    S3 Jock Member

    Joined:
    Dec 27, 2006
    Messages:
    84
    Likes Received:
    0
    [Oct 13, 2008]
    if it is otherwise 'driveable' i think you might have an airleak so check all airhoses, especially between the airbox and cam cover.
    #5
  7. jackadoodledo
    Offline

    jackadoodledo New Member

    Joined:
    Feb 5, 2009
    Messages:
    1
    Likes Received:
    0
    [Feb 24, 2009]
    i had the same thing, had the throttle body cleaned and it's back to normal
    i think the prob was caused by leaking exhaust making it overfuel?
    #6

Share This Page