1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A6 2.0T FSI Advice

Discussion in 'A6/S6/Allroad forum (C6 Chassis)' started by Molnboman, Apr 11, 2013.

  1. Molnboman
    Offline

    Molnboman Well-Known Member

    Joined:
    May 27, 2012
    Messages:
    1,179
    Likes Received:
    158
    [Apr 11, 2013]
    Hello, wondering if anyone can give me a bit of feedback. Am looking to upsize to the A6 Avant ( 2007 - 2008 vintage ) and was wondering if anyone has the 2.0t avant and could tell me what it was like drive wise in comparison to equivalent A4 with the same engine. Is there anything I should be looking out for? I have been very lucky with my current 2.0t bgb engined A4 avant, although I know they sometimes can be troublesome. Any advice or links to similar questions / answers would be greatly appreciated.

    Cheers
    A
    Last edited: Apr 11, 2013
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. Molnboman
    Offline

    Molnboman Well-Known Member

    Joined:
    May 27, 2012
    Messages:
    1,179
    Likes Received:
    158
    [May 29, 2013]
    Just giving this a Bump c'mon A6 owners....someone must have some knowledge with sharing!

    Cheers
    A
    #2
  4. elan2s
    Offline

    elan2s Member

    Joined:
    Aug 25, 2009
    Messages:
    210
    Likes Received:
    10
    [May 30, 2013]
    I think the problem you have here, is that compared to the Diesel there were only a handful of 2.0TFSI A6's sold to the point where there is no C7 2.0 petrol version sold. Sorry not to be of more help. Ignoring the engine the earlier C6 Avant's had a problem with the rear washer leaking. It either split in the rear LH pillar causing water to end up all over the MMI modules which are located behind the LH trim in the boot, or under the floor in the front passenger footwell, causing the CCM module (which handles central locking amongst other things) to fail. This is well documented on various forums but you should check that all of the MMI features work as intended and that there is no sign of water ingress behind the panel in the boot and also that the front passenger carpet is dry. Also check after using the rear washer and that it works with good pressure. Low pressure would suggest a leak
    #3

Share This Page