1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A6 1.9 TDI engine management ? - diagnostic codes

Discussion in 'A6/S6/Allroad forum (C5 Chassis)' started by oxford_hippo, May 15, 2010.

  1. oxford_hippo
    Offline

    oxford_hippo New Member

    Joined:
    Mar 2, 2010
    Messages:
    7
    Likes Received:
    0
    [May 15, 2010]
    Hi, bought a code reader from e Bay for our 2002, A6, 1.9 TDi, 130bhp avant, 130k miles on gthe clock.

    seems to have worked, and scanned the car's memory - but it came up with codes I couldn't see in the Reader booklet:

    17978;
    18058
    18057

    Does anyone know what these refer to.

    Problem background: Basically the car was parked up as usual, went back to it 1/2 hr later and it fired up, but revs/engined died instantly. Engine management warning light came on on dash:(.

    It has sat for about 4 weeks ( embarrassed to say too busy to get round to investigating ) put in a replacement battery as the other had gone dead - and it fired up fine, and has driven fine:drool:!???


    thanks for any pointers,
    T:drool:
    Last edited: May 15, 2010
    #1
  2. Ads

    Ads

    [Nov 24, 2014]

  3. garya6
    Offline

    garya6 New Member

    Joined:
    May 17, 2010
    Messages:
    7
    Likes Received:
    0
    [May 17, 2010]
    Hi I just had a problem with my a6 it had codes on it. The diesel tech said there should be no codes and cleared them all, one was because i had fitted a new wiring loom onto the injectors and when i disconnected it it sent a fault code to the cars computer another was when i disconnected the air flow meter then reconnected it. The faults even though rectified were still stored in the cars memory for some reason.
    Sorry dont know what the codes mean though
    #2
  4. evomaster3000
    Offline

    evomaster3000 Member

    Joined:
    Dec 8, 2004
    Messages:
    449
    Likes Received:
    3
    [May 18, 2010]
    #3
  5. oxford_hippo
    Offline

    oxford_hippo New Member

    Joined:
    Mar 2, 2010
    Messages:
    7
    Likes Received:
    0
    [May 18, 2010]
    evomaster many thanks for the suggestion - did google and came up with info on the engine being blocked by the immobiliser, and a prob. with the abs sendinga message..

    I'm a bit baffled as no work has been done recently on the car, that might have dislodged something? and the fault came on suddenly after the car had been driven fine 15misn earlier.

    One of the web sites suggets water getting in could affect connections - the drain hole under the battery had been checked while ago, but think a rear window might have been left open one night.....water it might ring true as the cause - because I've left the car for a few weeks - so ages for any water/moisture to dry out??

    Any places I could / should check for a water leak?
    Thanks, T
    #4

Share This Page