1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4cab roof problems

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Markymark79, May 14, 2011.

  1. Markymark79
    Offline

    Markymark79 New Member

    Joined:
    May 14, 2011
    Messages:
    1
    Likes Received:
    0
    Just bought a a4 cab on a 05 plate yesterday and got it home and tried ta take roof down and it stopped completely after a few seconds, done the open and close manually but saying roof not secure even tho it is. My boot won't open with button I have ta use the key, and I tried the roof this morning and it not workin at all!! Garage has said they fix it but can this turn into regular problem? Is it an easy fix?
    #1
  2. Iyole
    Offline

    Iyole N/A Rools

    Joined:
    Feb 12, 2011
    Messages:
    69
    Likes Received:
    0
    I haven't had any issues with my roof since buying the Cab 2 yrs ago.......so don't think it is a common/regular prob.

    Sounds like something related to the boot not opening with remote as the roof won't operate properly
    if the boot thinks it is open. Probably a Sensor somewhere giving problems

    Hope it is an easy fix.

    Keep us posted
    #2
  3. a4 cabrio
    Offline

    a4 cabrio Member

    Joined:
    Feb 10, 2011
    Messages:
    135
    Likes Received:
    0
    i have had no problems with my cabriolet either, only had mine since january, but so far so good.

    did you guy private or through dealer??? if a dealer, take it back too them. hope you get it sorted
    #3
  4. itsmeagain
    Offline

    itsmeagain 1.8T Sport Cabriolet

    Joined:
    Mar 6, 2010
    Messages:
    439
    Likes Received:
    0
    The boot sounds like the solenoid has packed up, real easy to change and only about £20 from memory. Just take the car to Audi and ask a technician to have a look. I got mine stuck months ago and they did it for me, they did the manual reset.
    #4
  5. Cabbyfan
    Offline

    Cabbyfan Member

    Joined:
    Jan 16, 2011
    Messages:
    687
    Likes Received:
    16
    If it says not secure it could be a micro switch in the boot, need to check fault codes to be sure or a manual open close (see handbook) might reset.
    #5
  6. kressy
    Offline

    kressy New Member

    Joined:
    Oct 10, 2010
    Messages:
    5
    Likes Received:
    1
    Hi,
    I have had a similiar issue with the roof on my 03 A4 cab ! it was working fine and i stupidly shut the car of half way into closing the roof! when i re-started the ignition the roof wouldnt work. I ended up doing a full manual open and close. Now when i try i can get the roof down in stages, I have to unlcok using th =e tool the latches from the front (windscreen) then the button works all the way back to the part before the boot opens, i then use the tool on the front latches again and close them in and then the button works all the way till close. this is the same when opening.... not sure if theres a motor section under the plastic in the roof (windscreen side) that may be broke...any ideas welcome..

    thanks
    #6
    Arthur eros likes this.
  7. VagPro
    Offline

    VagPro Member

    Joined:
    Feb 10, 2011
    Messages:
    367
    Likes Received:
    27
    Hi kressy, I doubt that you will have broken anything by switching it off midway, may have broken something during manual operation. I'd recommend to put it on vagcom and have a look. If you do need to replace the motors then drop me a message and I'll pull off the relevant sections off the workshop manual
    #7
  8. Cabbyfan
    Offline

    Cabbyfan Member

    Joined:
    Jan 16, 2011
    Messages:
    687
    Likes Received:
    16
    I have stopped mine during the cycle loads of times to clean or maintain and never had a problem. When they stop working its usually a micro switch in my experience.
    #8
  9. VagPro
    Offline

    VagPro Member

    Joined:
    Feb 10, 2011
    Messages:
    367
    Likes Received:
    27
    Hi cabbyffan, not had any problems with microswitches myself so can't comment on that, however it is useful to note that the motors for the hydraulic units are temperamental as they get older and poor conduction can also stop the system operating .

    http://www.audi-sport.net/vb/audi-s...et-soft-top-roof-hood-motor-repair-guide.html
    #9

Share This Page