1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4 tfsi rough idle and fails to start

Discussion in 'Audi S4/A4/A4 Cab (B8 Chassis)' started by Smythe, Oct 29, 2013.

  1. Smythe
    Offline

    Smythe New Member

    Joined:
    Jan 18, 2012
    Messages:
    2
    Likes Received:
    0
    I have a problem.. I problem that my local Audi dealership can't solve.
    I have a 2012 (facelift model) A4 2.0 tfsi stronic quattro that's clocked up 62000 miles (company car). Back in the summer the emmision control light came on, the car drove fine. I booked it in but they could find no problem, cleared the codes and sent me on my way. Around the same time the car would randomly fail to start. Either with the key or pushing the start button the car would turn over but not fire, the only way to start it was to apply some throttle. Strangely, if the car turned off at traffic lights (start/stop function) it would never fail to start as I wanted to move away!
    The car went back into the dealership, they did whatever they do, said they could not find anything and again gave me car back.
    The problem(s) then developed. The car still would still fail to start sometimes although getting more common, but also would rev up to 1200 rpm when stationary. Also would sometimes suffer from very rough idle and hesitation when pulling off!
    Back into audi. Now this time they noted that the car had had a remap. This was done when the car was 3 weeks old by a reparable company who have actually won 'audi tuner of the year' from 2007 to 2012 so have faith it what work they have done. My dealership told me that because of this map any work carried out on either the engine, gearbox or drivetrain would no longer be carried out under warranty. Good news though, they had traced problem to no.1 fuel injecter so replaced it as well as spark plug, bad news, they charged me £450. Got the car back but within days all symptoms returned.... Back to audi!
    They advised that the problem could be the map so removed it. I had used vagcom to add ADS to the MMI for the purpose of steering and gearbox economy program but that too has been removed ( although it remains greyed out in car menu.)
    Again I had car back but within a day problems are all back. I have checked plugs and they are all black and sooty. When slowing in traffic I can hear 'popping' through exhaust suggesting over fueling?
    When the car is running rough, if I gently remover oil filler cap, there is suction from vacuum, the car shudders and stalls. When the car is running fine, removing the oil filler cap results in the engine tick over increasing.
    I have pulled the following codes


    P2188 - Bank 1; System too Rich at idle
    P2178 - Bank 1; System Too Rich at idle
    P0301 - Cylinder 1: Misfire detected


    I am sure I also read one at some time about there being an air leak in intake system? (Yes I have checked but can't see one.)


    Incidentally, the emmision control light would sometimes flash and sometimes (rarely) accompanied by the EPC light.


    Thanks in advance for any comments and or help.


    Andy
    #1
  2. NHN
    Offline

    NHN Modmetractor Site Sponsor

    Joined:
    Jan 14, 2008
    Messages:
    27,221
    Likes Received:
    1,219
    Has audi reflashed the ecu or just got your tuner to remove the map & who is the tuner?
    #2
  3. W8 Performance
    Offline

    W8 Performance Member

    Joined:
    Nov 22, 2004
    Messages:
    929
    Likes Received:
    18
    This thread mentions issues with various things to check. HPFP solved a few issues by the look of it, have you had the cam follower changed recently?

    P0172 suggestions? - Page 2
    #3
  4. Smythe
    Offline

    Smythe New Member

    Joined:
    Jan 18, 2012
    Messages:
    2
    Likes Received:
    0
    NHN, audi flashed the ecu, the tuner was MRCtuning.

    W8 Performance, what effect has a worn cam follower?

    thanks for your replies guys...
    #4
  5. NHN
    Offline

    NHN Modmetractor Site Sponsor

    Joined:
    Jan 14, 2008
    Messages:
    27,221
    Likes Received:
    1,219
    MRC know there beans so that's not even a discussion point afaik.

    Ok I would check with MRC & ask if they are recommended or used by any audi dealer at all, if so then this is a way in I reckon, but the fact audi have reflashed the ecu & it still does it, then they should really do this under warranty IMHO.

    (Welcome back Rob, where you been hiding :)
    #5

Share This Page