1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4 randomly showing traction and ABS lights

AudidriverA4 Apr 6, 2013

  1. AudidriverA4

    AudidriverA4 Member

    183
    5
    18
    Hi all,

    Just noticed over the last week my car has randomly starting displaying the TC and ABS lights as I'm driving along.


    Any ideas anyone what could be wrong with the car?

    Car is driving perfectly though :blink:
     
  2. Mollygoogle

    Mollygoogle Member

    252
    9
    18
    Have you got aftermarket HID's
     
  3. quattrojames

    quattrojames Moderator Staff Member Moderator Audi A6 Audi Avant Owner Group

    14,050
    578
    113
    Check the brake lights, it might be a faulty switch.
     
  4. AudidriverA4

    AudidriverA4 Member

    183
    5
    18
    No Hids's and brake lights are all working :uhm:
     
  5. Mollygoogle

    Mollygoogle Member

    252
    9
    18
    My money is on the HID ballast causing interference
     
  6. Ian2012

    Ian2012 Active Member

    473
    29
    28
    could be earthing have you scanned the car for fault codes?? that would be my first port of call
     
  7. AudidriverA4

    AudidriverA4 Member

    183
    5
    18
    Hi Mollygoogle, sorry my car has the standard bulbs in it.

    That would be mine too Ian but, I have no VAGCOM just started the tread to see if it could be a simple fix, as I'm sure the car is not displaying the lights for no reason :think:
     
  8. quattrojames

    quattrojames Moderator Staff Member Moderator Audi A6 Audi Avant Owner Group

    14,050
    578
    113
    If it's none of the obvious we're all guessing really, ABS sensor would be my next guess.
     
  9. Ian2012

    Ian2012 Active Member

    473
    29
    28
    You need to find a forum member with vcds to help out, or invest in the system yourself, if you are into audi's longterm then it will save you a fortune in diagnostic costs, mine has saved me a fortune over the years.

    It could be your abs ecu is on the way out, but really without plugging in diagnosing it's hard to say.
     
  10. Neilb1

    Neilb1 Member

    178
    2
    16
    intermittent brake light switch, it might be working when you check it, mine did the same
     
  11. Mollygoogle

    Mollygoogle Member

    252
    9
    18
    Sorry, misread your first response about no HID's
     
  12. AudidriverA4

    AudidriverA4 Member

    183
    5
    18
    Thanks again for all the replies I know its impossible to diagnose to problem without a scan, your replies will just give me an idea what could be wrong with the car,

    This could be it, the next time the happens again I'll check my breake lights, hopefully that's all thats wrong with it :laugh:
     
  13. AudidriverA4

    AudidriverA4 Member

    183
    5
    18
    No problem mate.
     

Share This Page