1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4 not revving past 3000

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by swalder, Dec 28, 2013.

  1. swalder

    swalder Member

    Joined:
    Jul 25, 2013
    Messages:
    75
    Likes Received:
    1
    Guys out shopping :( so kind of hard to search every post but had a look and looking some advice.

    Merging onto the motorway behind a slow moving horse trailer. So accelerateon past then all of a sudden power dropped out and it was a struggle to hold 60mph.

    No power in any gear and I can't hear the turbo . Once I got off the motorway found the car won't rev past 3000rpm.

    I am now way technical but from reading maybe the maf has gone or the hose for the tyrbo.

    Anyone any suggestions on what can be done or what I should look at?

    Its a 2.0 tdi

    Cheers guys
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. Molnboman

    Molnboman Well-Known Member

    Joined:
    May 27, 2012
    Messages:
    1,338
    Likes Received:
    191
    Any warning lights on your dashboard? Sounds like your car has gone into limp mode.

    BR
    A
     
  4. Broken Byzan

    Broken Byzan Photographic Moderator
    Staff Member Moderator VCDS Map User Audi A4 quattro

    Joined:
    Apr 26, 2004
    Messages:
    13,004
    Likes Received:
    388
    boost pipe off? Is it smoking a lot of black smoke when it is working?

    You could try disconnecting maf to get you home and drive carefully
     
  5. swalder

    swalder Member

    Joined:
    Jul 25, 2013
    Messages:
    75
    Likes Received:
    1
    I am not technical in any way . Can you point to me where the boost pipe is ? I could have a look ?

    Although if it were off completely surely the turbo wouldn't spool at all. Just the second drive there albeit short to the next shopping centre :( the turbo was engaging and it operating normally again.
     
  6. swalder

    swalder Member

    Joined:
    Jul 25, 2013
    Messages:
    75
    Likes Received:
    1
    just a bit more of an update drove home around 15 miles . Everything was fine , drove normally didnt horse it or demand too much pressure onto the turbo.

    Cant understand why it would have entered limp mode as the dash had zero warning lights etc.
     
  7. Broken Byzan

    Broken Byzan Photographic Moderator
    Staff Member Moderator VCDS Map User Audi A4 quattro

    Joined:
    Apr 26, 2004
    Messages:
    13,004
    Likes Received:
    388
    ok, i'd be getting it scanned for faults. I cannot imagine an intermittent fault will remain so for long
     
  8. hubbo1

    hubbo1 Member

    Joined:
    May 14, 2012
    Messages:
    96
    Likes Received:
    4
    if it went into limp mode because of sticking turbo vanes, its unlikely to throw up a warning light.
    before I cleaned my turbo mine used to do this-foot down and bang=into limp mode, turn engine off and back on again=all normal.
     
  9. swalder

    swalder Member

    Joined:
    Jul 25, 2013
    Messages:
    75
    Likes Received:
    1
    How hard is it to clean the turbo or how expensive to get a mechanic to do it ?

    Cheers for the help .
     
  10. hubbo1

    hubbo1 Member

    Joined:
    May 14, 2012
    Messages:
    96
    Likes Received:
    4
    just search on here for "mr muscle" turbo clean, its not a hard job, just search- sticky for turbo cleaning, its all in that thread
     
    #9 hubbo1, Dec 28, 2013
    Last edited: Dec 28, 2013
  11. swalder

    swalder Member

    Joined:
    Jul 25, 2013
    Messages:
    75
    Likes Received:
    1

    cheers buddy !
     

Share This Page