1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4 not revving past 3000

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by swalder, Dec 28, 2013.

  1. swalder
    Offline

    swalder Member

    Joined:
    Jul 25, 2013
    Messages:
    75
    Likes Received:
    0
    Guys out shopping :( so kind of hard to search every post but had a look and looking some advice.

    Merging onto the motorway behind a slow moving horse trailer. So accelerateon past then all of a sudden power dropped out and it was a struggle to hold 60mph.

    No power in any gear and I can't hear the turbo . Once I got off the motorway found the car won't rev past 3000rpm.

    I am now way technical but from reading maybe the maf has gone or the hose for the tyrbo.

    Anyone any suggestions on what can be done or what I should look at?

    Its a 2.0 tdi

    Cheers guys
    #1
  2. Molnboman
    Offline

    Molnboman Active Member

    Joined:
    May 27, 2012
    Messages:
    1,151
    Likes Received:
    7
    Any warning lights on your dashboard? Sounds like your car has gone into limp mode.

    BR
    A
    #2
  3. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,568
    Likes Received:
    9
    boost pipe off? Is it smoking a lot of black smoke when it is working?

    You could try disconnecting maf to get you home and drive carefully
    #3
  4. swalder
    Offline

    swalder Member

    Joined:
    Jul 25, 2013
    Messages:
    75
    Likes Received:
    0
    I am not technical in any way . Can you point to me where the boost pipe is ? I could have a look ?

    Although if it were off completely surely the turbo wouldn't spool at all. Just the second drive there albeit short to the next shopping centre :( the turbo was engaging and it operating normally again.
    #4
  5. swalder
    Offline

    swalder Member

    Joined:
    Jul 25, 2013
    Messages:
    75
    Likes Received:
    0
    just a bit more of an update drove home around 15 miles . Everything was fine , drove normally didnt horse it or demand too much pressure onto the turbo.

    Cant understand why it would have entered limp mode as the dash had zero warning lights etc.
    #5
  6. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,568
    Likes Received:
    9
    ok, i'd be getting it scanned for faults. I cannot imagine an intermittent fault will remain so for long
    #6
  7. hubbo1
    Offline

    hubbo1 Member

    Joined:
    May 14, 2012
    Messages:
    94
    Likes Received:
    0
    if it went into limp mode because of sticking turbo vanes, its unlikely to throw up a warning light.
    before I cleaned my turbo mine used to do this-foot down and bang=into limp mode, turn engine off and back on again=all normal.
    #7
  8. swalder
    Offline

    swalder Member

    Joined:
    Jul 25, 2013
    Messages:
    75
    Likes Received:
    0
    How hard is it to clean the turbo or how expensive to get a mechanic to do it ?

    Cheers for the help .
    #8
  9. hubbo1
    Offline

    hubbo1 Member

    Joined:
    May 14, 2012
    Messages:
    94
    Likes Received:
    0
    just search on here for "mr muscle" turbo clean, its not a hard job, just search- sticky for turbo cleaning, its all in that thread
    Last edited: Dec 28, 2013
    #9
  10. swalder
    Offline

    swalder Member

    Joined:
    Jul 25, 2013
    Messages:
    75
    Likes Received:
    0

    cheers buddy !
    #10

Share This Page