1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4 KEY CODE PROBLEM

Discussion in 'A4/S4 forum(B5 Chassis)' started by anwar, Jun 8, 2003.

  1. anwar
    Offline

    anwar Member

    Joined:
    Apr 3, 2003
    Messages:
    35
    Likes Received:
    0
    [Jun 8, 2003]
    Is anyone know that Audi a4 got problem in there key codes & when you start car it switched off itself its sound like petrol problem but actually I found out it is a key code & car don’t recognize. One of my friend gave his car to Audi to sort this out & they charge him £140 but the problem still there he went back to them but they are saying its a normal Audi problem. Is anyone known about this problem & how we can solve this please advice? Thanks /ubbthreads/images/graemlins/confused.gif
    #1
  2. Ads

    Ads

    [Sep 16, 2014]

  3. Cupramax
    Offline

    Cupramax Uber pimp meister

    Joined:
    Jan 19, 2003
    Messages:
    457
    Likes Received:
    0
    [Jun 9, 2003]
    I had a similar problem to this on my old Toledo V5 which uses the same VAG immobilizer and works by reading the key code. You could start the car but then it cut out and the ECU/Key light flashed meaning it didn't recognise the key.

    They ended up replacing the ignition barrel key code reader on mine which is part of the ignition barrel to sort the problem. This doesn't always show up as a fault on the factory diagnostics machine so can be hard to trace.

    Hope this helps. /ubbthreads/images/graemlins/wink.gif
    #2
  4. Simon
    Offline

    Simon Member

    Joined:
    Jan 2, 2003
    Messages:
    73
    Likes Received:
    0
    [Jun 9, 2003]
    Sorry about the OT post but you are not accepting PM's

    I only have the front skirt available now but you can have it for £100 plus dely costs.

    Simon
    #3
  5. Golfather
    Offline

    Golfather Member

    Joined:
    Mar 26, 2003
    Messages:
    33
    Likes Received:
    0
    [Jun 9, 2003]
    Audi's seem to be worse than VW with all these probs !!
    If the key symbol is shown, then yes the immobliser is switched on - either a fault in the key you are using
    or in the barrel or in the main immobiliser unit.
    Need to check if you have any fault codes with the alarm.
    If not, then I'm afraid you're gona have to change each item one at a time until it solves the problem.
    Audi should be able to track down the problem. Depends on how competent their electricians are.

    If it isnt the immobiliser, could be your throttle body, fuel pump etc etc
    #4
  6. anwar
    Offline

    anwar Member

    Joined:
    Apr 3, 2003
    Messages:
    35
    Likes Received:
    0
    [Jun 9, 2003]
    thanks you everyone for help. golfather we have to sort this problem out its not a fuel pump its a key code & even audi cant cant fix it my friend tried it he paid £140 for this. /ubbthreads/images/graemlins/cry.gif
    #5
  7. Patrick
    Offline

    Patrick Member

    Joined:
    Jan 7, 2003
    Messages:
    153
    Likes Received:
    0
    [Jun 13, 2003]
    If they charged your friend £140 for not fixing the problem I'd go right back until they do. ON the basis that your freind shelled out money for nothing! If they give you any grief talk to Audi customer services they are not entirely useless.

    I had to take my S4 back 14+ times over six months to my local dealership until they finally fixed my ECU/immobilser problem. Neither them or Audi UK technical knew the new ECU was looking for a rolling code instead of the orginal fixed code. I got all the work done at Audi's expense as the ECU was a recall that had never been carried out. /ubbthreads/images/graemlins/burningmad.gif
    #6

Share This Page