1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4 ICE upgrade, ignition problem

Discussion in 'In-Car Entertainment' started by stuart_75, Mar 25, 2007.

  1. stuart_75
    Offline

    stuart_75 Member

    Joined:
    Mar 25, 2007
    Messages:
    60
    Likes Received:
    0
    [Mar 25, 2007]
    Hi all, first time poster so be gentle.

    I have a 2003 A4 with a Symphony 2 and bose rear amplified. Im currently attemping to put a single DIN Sony head unit in. I have the converter lead with pre-outs to fit straight into the Sony.

    My problem is, when checking the 12v ignition source I get 11v when on and 0v when ignition off (so far so good). But when I connect the ignition source to the Sony, the voltage drops down to near as nothing and the HU doesnt function correctly.

    Shall I just tap into another switched 12v and use that? If so, where shall I take it from?

    Thanks!
    #1
  2. Ads

    Ads

    [Dec 19, 2014]

  3. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Mar 25, 2007]
    2003 A4's don't have an ignition on feed to the HU. They use the CANBUS to tell the HU when the ignition is on.
    You need to either pair the permanent live with the ignition on feed to the Sony HU and turn it on/off manually, or create an ignition on feed for the new HU.
    Unfortunately there is no easy feed to tap into. They are all either perm live or only live when ignition is fully on i.e. they go off when you turn the ignition off and don't stay live until you pull the keys out, which is what you really need.
    If you don't mind the HU turning off when you turn the engine off then you can tap a feed at the fusebox, there are plenty of options there.
    If you want a proper ignition on feed i.e. the HU stays on until you pull the keys out, then you need to wire in a relay. The trigger to use for the relay is under the steering column. Remove the trim under the steering wheel and you will see the main loom from the ignition switch running under the left side of the steering column. You'll see some black trunking protecting the loom. Release this trunking so you can get to the wires. You'll see a very thin red wire in amongst all the other thicker wires. This is the one you want.
    With the ignition off and the keys out, chop this wire and reconnect it with a small terminal block along with another wire that you can then run to the relay. Unfortunately the wire is so thin that you can't get a reliable feed using a piggyback connector.
    This is a very low current feed so you can't power the HU directly from it. Just wire in a 12v relay using piggyback connections from the perm live & earth at the HU and use this new wire to switch the relay on/off, then use the other side of the relay to power the HU. Sounds more complicated than it actually is, took me 30-45 minutes to do mine, but well worthwhile otherwise you need to have the keys turned to ignition on to get the HU to work when parked up.
    #2
  4. stuart_75
    Offline

    stuart_75 Member

    Joined:
    Mar 25, 2007
    Messages:
    60
    Likes Received:
    0
    [Mar 26, 2007]
    Thank you very much for the reply.

    Ill tap into the fuse box I think.

    Shall I just pick a any wire that has a switched 12v?

    One more thing, I thought the sound levels coming through the rear speakers via the pre outs-bose amp were very poor compared to the front. Do I just need to adjust the fader the level them up?

    Cheers!

    Stuart.
    #3
  5. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Mar 26, 2007]
    Yes anyone will do.
    Yes the fronts will be unbalanced as the new HU will have at least twice the power of the old Symphony which was only 2 x 20w, so you'll need to fade to rear to get them back in line.
    BTW you don't have a Bose system as all speakers are amped in a Bose setup so you would not be getting this balance problem. Only non Bose systems run the front speakers off the HU.
    #4
  6. stuart_75
    Offline

    stuart_75 Member

    Joined:
    Mar 25, 2007
    Messages:
    60
    Likes Received:
    0
    [Mar 26, 2007]
    Thanks for the advice. Ive just ordered a symphony facia adaptor.

    I have a JBL 6 channel channel gathering dust in the garage. Is getting a power supply off the battery for it easy? And where would you suggest to best place to install it would be? Also would the standard speakers do it any justice or would they need swapping?

    Ive had it in a couple cars previous, but they were Fords and installing amps in them are easy.

    Audi's seem built like tanks in comparrison.
    #5
  7. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Mar 26, 2007]
    Running power is easy, just use the spare grommet on the ECU cover and that drops down into the drivers footwell. You'll nee to remove the visible bolts on the top and prise up the front edge which will give you enough room to guide the cable through.
    Definately change the front components, they are 6.5" with a 1" tweeter and they're bolted to the actual door rather than the door card so you can get really good mid-bass from them. You will need to build some big spacer rings as the stock units stand away from the door skin by about 40mm and on non Bose these spacers are part of the speaker. I just used 2 rings of 18mm MDF glued and screwed together with a larger 6mm MDF ring on the back to secure it to the door using the existing mounting points.
    [​IMG]

    The biggest problem is what to do with the tupperware sub/rear amp combo. I ripped mine out and used the space to accomodate an Alpine V12 4ch amp. Then on the other side cut the back off the cubbyhole and installed a small MDF enclosure & JL Audio sub (this is on the Avant B6 A4). The transformation was dramatic so well worth doing.
    [​IMG]
    [​IMG]
    [​IMG]
    #6
  8. stuart_75
    Offline

    stuart_75 Member

    Joined:
    Mar 25, 2007
    Messages:
    60
    Likes Received:
    0
    [Mar 26, 2007]
    Cheers for the pics.

    Thats got me thinking now. How difficult are the doors to strip apart?
    #7
  9. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Mar 26, 2007]
    Pretty easy but you need to get some spare pop fasteners as they're designed to break when you take the door card off (rather than destroy the door card). Just remove the top trim panel, prise it up at the end furthest from the hinges. Remove all the screws shown below then aggressively prise it away from the door.
    [​IMG]
    #8
  10. Caesium
    Offline

    Caesium My BM is fixed!

    Joined:
    May 26, 2004
    Messages:
    4,879
    Likes Received:
    4
    [Mar 26, 2007]
    I think the 2003 A4 was too early for the CAN-BUS its K line I believe? (not picking just trying to clarify)
    I took my switched live (for a nokia car kit) from the steering column, there is a long slender plastic sheild that allows the column wiring to extend when the column reach is adjusted, in there is a switched feed, just meter it out.
    #9
  11. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Mar 27, 2007]
    Yes Chris I did the same, I think it was you who told me about it. I stuck a relay on this feed as it was a very thin wire so very low current.
    #10
  12. Caesium
    Offline

    Caesium My BM is fixed!

    Joined:
    May 26, 2004
    Messages:
    4,879
    Likes Received:
    4
    [Mar 27, 2007]
    Andy have you got VAGCOM, its just that I bought it the other day, and cant connect to my radio at all, just wondered if you had ever tried it.
    #11
  13. timps
    Offline

    timps Shakersville

    Joined:
    Oct 2, 2005
    Messages:
    235
    Likes Received:
    0
    [Mar 27, 2007]
    #12
  14. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Mar 27, 2007]
    Sorry Timps, respect due.
    Chris, no never used it sorry.
    #13
  15. dualmono21
    Offline

    dualmono21 Well-Known Member

    Joined:
    Dec 9, 2006
    Messages:
    1,056
    Likes Received:
    61
    [Mar 29, 2007]
    nice work andy

    id also advise the use of sound deadening material such as dynamatt or skinz even the cheaper ivanhoe is a very good product
    it makes a very big differance to the sound when you have spent a little time deadening them
    someting i can also reccomend is something from skins called "moisture guard" which is designed to stop water and condensation from destroying your new speakers

    i do have some pictures of mine but as yet i cannot post attachments
    #14

Share This Page