1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4 Brakes problem

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by patricktshuma, Dec 3, 2010.

  1. patricktshuma
    Offline

    patricktshuma New Member

    Joined:
    May 16, 2010
    Messages:
    3
    Likes Received:
    0
    [Dec 3, 2010]
    The rear right wheel brakes got locked, I managed to get the car to the garage, The garage guy removed the pads, checked the caliper all seemed good. While testdriving the brake pedal sometimes feels hard with no brakes at all. now I'm being quoted over £500.00 as the guy is saying the brake servo unit needs replacing.

    What else can be wrong? not the right time to be parting with that amount of money....

    Patrick
    #1
  2. Ads

    Ads

    [Sep 22, 2014]

  3. markA4tdi
    Offline

    markA4tdi markA4tdi

    Joined:
    Nov 19, 2009
    Messages:
    105
    Likes Received:
    1
    [Dec 3, 2010]
    I disagree with the diagnosis here, if the seals in the brake servo were knackered, you would lose pressure in the servo, as the brake fluid would leak past the seals, personally what i would do first is change the brake fluid (an easy job and relatively inexpensive) brake fluid over time absorbs water and should be changed every 2 years) secondly as daft as this sounds, just check for water in the battery/servo area (make sure it hasnt frozen in these low temperatures) mine did this in january this year, my fronts locked up under heavy braking and wouldnt release untill after 10 to 15 mins.
    after a brake fluid change and much later removal of the rubber bungs in the bulk head area, all was good.....cost ......£14 for 5 litres of brake fluid. (yep i know you dont need 5 litres but i made sure i flushed all the old out.
    for info if your brake servo seals were gone your pedal would slowly go to the floor depending on how knackered your seals were
    ps im assuming he ruled out a sticking/locked caliper? if he didnt, get this checked, with the wheel off, get someone to press the brake pedal, and you watch if the pads are pressing and retracting from the disc.
    Last edited: Dec 3, 2010
    #2
    Baza1819 likes this.
  4. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,892
    Likes Received:
    477
    [Dec 3, 2010]
    I'd agree with Mark - blocked drain plugs in the plenum chamber and a frozen servo sounds very likely.
    #3
  5. desperado
    Offline

    desperado New Member

    Joined:
    Dec 3, 2010
    Messages:
    1
    Likes Received:
    0
    [Dec 3, 2010]
    I know Audi were doing recall stuff on brake servos etc...
    I only got my b6 a month ago and the garage I bought it from made Audi sort it foc, maybe it's worth trying??
    #4
  6. patricktshuma
    Offline

    patricktshuma New Member

    Joined:
    May 16, 2010
    Messages:
    3
    Likes Received:
    0
    [Dec 3, 2010]
    Thanks mate, I will pick the car from the garage tomorrow, as I had aready told them not to continue with the repairs.
    #5
  7. markA4tdi
    Offline

    markA4tdi markA4tdi

    Joined:
    Nov 19, 2009
    Messages:
    105
    Likes Received:
    1
    [Dec 3, 2010]
    they did do a recall, but all they do is clean the rubber bungs free of debris, (they are supposed to replace the bungs with a new more efficient designed one, but they didnt with mine and sure enough they blocked back up again, so i removed mine to prevent it from happening again. audi would charge to change the fluid (about 48 quid iirc)
    #6
  8. markA4tdi
    Offline

    markA4tdi markA4tdi

    Joined:
    Nov 19, 2009
    Messages:
    105
    Likes Received:
    1
    [Dec 3, 2010]
    good, you just saved yourself a huge sum of money, there are loads of knowledgable fellow owners on here always happy to help and offer advice (i sound like i work at a supermarket here dont I ... i dont (i couldnt give my daily dose of gore blood and guts up!) (before u wonder, i work in the operating theatres! lol
    Last edited: Dec 3, 2010
    #7
  9. pj123
    Offline

    pj123 Member

    Joined:
    Oct 5, 2010
    Messages:
    295
    Likes Received:
    9
  10. pj123
    Offline

    pj123 Member

    Joined:
    Oct 5, 2010
    Messages:
    295
    Likes Received:
    9
    [Dec 3, 2010]
    (that was a link by the way)
    #9
  11. patricktshuma
    Offline

    patricktshuma New Member

    Joined:
    May 16, 2010
    Messages:
    3
    Likes Received:
    0
    [Dec 13, 2010]
    Just to update, I collected the car from the garage and the guy had already changed the brake fluid..... but still no brakes. Took the car to audi in manchester, last friday they confirmed the brake cylinder needs changing. I then mentioned the recall on these cars and they agreed to raise the case with Audi UK. Today I got a text saying Audi Uk have agreed to pay for the repairs.....
    #10
  12. scott b
    Offline

    scott b Active Member VCDS Map User

    Joined:
    Jan 19, 2010
    Messages:
    1,254
    Likes Received:
    3
  13. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Dec 13, 2010]
    replaced servos on two a4s of this era due to corrosion on the insides rendering these inop. in the last few months........ brake pedal hard and next to no brakes.......
    #12
  14. markA4tdi
    Offline

    markA4tdi markA4tdi

    Joined:
    Nov 19, 2009
    Messages:
    105
    Likes Received:
    1
    [Dec 21, 2010]
    can you believe it! this has happened to me this am, my car dosnt do many miles at all (3-4k a year) now this morning i started it up to give it a run out, charge the battery etc, the brake pedal was hard as mentioned in above posts, although did give a little but with very little braking effect) i remember this happening around january this year too, so back then i drove (carefully and with lots of distance between cars on motorway) after about 30 mins, what ever it was that thawed out did and braking was returned to normal. so this morning i did the same, drove up motorway for about 25-35 mins, at operating temperature 90, pedal gave initially but then very hard with no or very little braking effect at all, turned around headed for home, called in to audi main dealer at teesside to get a quote, first explained the recall about plenum chamber etc, said after it had been in there, 3 months later was full of water again, so i removed the rubber grommets to prevent it all reoccurring, he agreed he thought it may need just the servo doing...prices as follows £585.65 all in. or part only £255.65 the rest was 3 hours labour. so i tried to get some knocked off, they wernt having any of it saying as it was over a year since the plenum chamber recall.

    so i left and came home, &%$$ me as soon as i started driving away......full brakes back! braking back to normal, pedal as it used to be before the hard frosts and perfect braking again, abs all working as it should esp all working as it should, so does this still point to the servo needing replacing?? btw no water frozen in the bulkhead area, and as my car has been stood for a fortnight in recurrent minus figures (last 4 nights as low as minus 10 each night), could it be something else?? i have had the brake fluid changed and all brake cylinders are all ok.
    Last edited: Dec 21, 2010
    #13

Share This Page