1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4 B7 Sat Nav coding

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by goldent, Aug 22, 2013.

  1. goldent
    Offline

    goldent New Member

    Joined:
    Oct 9, 2012
    Messages:
    2
    Likes Received:
    0
    [Aug 22, 2013]
    Hi can anyone help me on this I seem to have hit a brick wall.

    I have fitted a sat nav (8E0 035 192 T), bluetooth and MFSW into my a4 B7 1.9TDV SE, but cannot access the sat nav module to re-code. i have VAGCOM and have recoded the instrument cluster and the MFSW but it will not access the sat nav or bluetooth modules. I have read there may be K-line missing from the sat nav / wiring loom, as it was a concert II before, but do I need this to access as I found another forum which advised moving one pin from the 'c' wiring block to the 'b' block which I tried but it didnt work.

    I went in to AUDI to get some advice and the guy on parts said I needed an SVM code?? I thought these were for B8 platforms and later??

    Thanks in advance.
    #1
  2. Ads

    Ads

    [Sep 16, 2014]

  3. B5NUT
    Online

    B5NUT Well-Known Member VCDS Map User

    Joined:
    Feb 6, 2010
    Messages:
    2,285
    Likes Received:
    258
    [Aug 22, 2013]
    SVM.. O dear, Audi dealers know F*** all about retrofits so it's pointless asking them. Where did you get the wiring harness adapter from, if it was ebay then it's most likely the cause of the k-line fault for the RNS-E. Look on the concert 2 and you should see the K-line (may be marked as K or K-Bus) follow the wire and it should go to pin 5 on the B connector if it's not then you need to move the wire.

    For the BT module how did you connect to the K-line is it off the wiring harness adapter? Also do you know what car the the BT unit was taken from or was it new?
    #2
  4. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,319
    Likes Received:
    1,229
    [Aug 23, 2013]
    As above, fix kline & then test, svm is irrelevant in this situation.
    #3
  5. goldent
    Offline

    goldent New Member

    Joined:
    Oct 9, 2012
    Messages:
    2
    Likes Received:
    0
    [Aug 23, 2013]
    Thanks both for the replies,
    The bluetooth module is an 8P0862335M used module off ebay and the wiring harness is a carsystems.pl which I believe is ok.

    I had another look at it today and removed the RNSE and wiring and put the concert II back in but still couldn't access the concert II through VAGCOM (KLINE on C7). I then connected the wiring harness to the concert and the bluetooth module, couldn't access through vagcom but the bluetooth module worked ok and the DIS shows the telephone information etc. and I could use the MFSW controls to make & recieve telephone calls.

    The kline was connected to C7 on the concert II. I re-fitted the RNSE and connected the Kline to B5 but still no VAGCOM access.
    #4
  6. B5NUT
    Online

    B5NUT Well-Known Member VCDS Map User

    Joined:
    Feb 6, 2010
    Messages:
    2,285
    Likes Received:
    258
    [Aug 23, 2013]
    Have you got a multimeter check pin 7 on the diagnostic socket to pin 3 on the 8pin black connector on the radio, that should buzz out but if not then you could just put a temporary wire between the socket and the radio to see if that cures the fault.
    #5
  7. phil_w
    Offline

    phil_w Member VCDS Map User

    Joined:
    Nov 2, 2008
    Messages:
    389
    Likes Received:
    13
    [Aug 23, 2013]
    I've had a carsystems.pl loom before and k-line was missing.
    #6

Share This Page