1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A4 2.0TFSI Screeching noise

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by heli_madken, Aug 30, 2013.

  1. heli_madken
    Offline

    heli_madken Member

    Joined:
    Mar 26, 2008
    Messages:
    117
    Likes Received:
    0
    Hi Everyone,

    I have what sounds like a big problem which I think may be Turbo bearings, here are the symptoms - Everything fine when cold, engine idles and revs fine with no noises.

    When she gets warm I get a horrible screeching noise at idle and on the move when taking my foot off the gas, under load she is fine.

    No appreciable loss of power but idle RPM rises to around 1400 and hunts

    Cant really pinpoint the noise, I am guessing its Turbo related with the change in RPM, but reading around most failures seem to result in noise when revving the engine not when off throttle, engine management light comes on when the noise is there but does go off when starting from cold

    Any ideas? car has been regularly serviced with an Oil change in March

    Any help would be appreciated
    Ken
    #1
  2. heli_madken
    Offline

    heli_madken Member

    Joined:
    Mar 26, 2008
    Messages:
    117
    Likes Received:
    0
    Just a thought, if it was the turbo bearings would I expect to see a lot of smoke from the exhaust? any help would be appreciated
    #2
  3. drew306
    Offline

    drew306 Member

    Joined:
    Aug 21, 2012
    Messages:
    31
    Likes Received:
    3
    It's not the alternator belt or something silly like that? Also get it scanned with Vcds software, this will show up any errors that have been logged when your engine management light came on.
    #3
  4. Molnboman
    Online

    Molnboman Well-Known Member

    Joined:
    May 27, 2012
    Messages:
    1,152
    Likes Received:
    151
    Am no expert Mate...but if your turbo was knackered you would know all about it....White smoke from your exhaust if it's gubbed. Can you remove the oil cap at idle?...if not, it might be your PCV valve. My engine revs were hunting and I was getting a EML light on and poor mpg.....it cured it. Lots of issues and quite a few symptoms when the PCV goes. One is a high pitch whistling sound. You could also try some belt dressing spray to eliminate the V belt being the issue. ......Have you had it checked for fault codes yet?

    Cheers
    A
    Last edited: Sep 3, 2013
    #4
  5. heli_madken
    Offline

    heli_madken Member

    Joined:
    Mar 26, 2008
    Messages:
    117
    Likes Received:
    0
    Thanks A, I have to admit that the noise in this video is exactly the same I am convinced of it - audi engine noise.m4v - YouTube will take a look tonight and let you know, one thing why would it happen only when she is warm?

    Is the round black assembly the PCV valve?

    Thank you for the help really appreciated, Ken
    #5
  6. craichouse
    Offline

    craichouse Member

    Joined:
    Dec 19, 2012
    Messages:
    88
    Likes Received:
    7
    its the Air con pulley. the exactly same thing is happening to mine, Exactly
    my mechanic says it is a common fault with the air con pulley

    getting mine sorted next week
    #6
  7. craichouse
    Offline

    craichouse Member

    Joined:
    Dec 19, 2012
    Messages:
    88
    Likes Received:
    7
    #7
  8. heli_madken
    Offline

    heli_madken Member

    Joined:
    Mar 26, 2008
    Messages:
    117
    Likes Received:
    0
    Thanks for your help, it looks like Molnboman is spot on thank you, when I checked last night by running the engine it was difficult to remove the oil cap and when I did air was sucked into the engine, new PCV on order, thanks for your help, Ken
    #8

Share This Page