1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

a4 1.8 running problems please help

Discussion in 'A4/S4 forum(B5 Chassis)' started by lewisdale, Jun 15, 2010.

  1. lewisdale
    Offline

    lewisdale New Member

    Joined:
    Jun 15, 2010
    Messages:
    2
    Likes Received:
    0
    [Jun 15, 2010]
    my v plate a4 is a 1.8 non turbo se model, recently its started to play up quite badly, now from cold it starts and ticks over lovely but doesnt rev cleanly, and as soon as the electronic choke turns off it wont idle atall and coughs and splutters and struggles to get to 4500 rpm, renewed the plugs, and they were black as if too rich, is this anything anyone else has had and are there any easy fixs? or common faults i should be looking for? thanks guys i really need this sorted as its barely driveable ​
    #1
  2. Ads

    Ads

    [Sep 21, 2014]

  3. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,603
    Likes Received:
    276
    [Jun 15, 2010]
    Without a fault code it is difficult, but it is probably the temperature sender. It would be worth the £20 to replace it to see if that fixexs the problem.

    The car more likely thinks it's cold all the time and stays on choke thus running too rich al the time
    #2
  4. lewisdale
    Offline

    lewisdale New Member

    Joined:
    Jun 15, 2010
    Messages:
    2
    Likes Received:
    0
    [Jun 15, 2010]
    hi thanks for youre help,butif its what youre saying then why would it still not rev right from cold even though it idles ok?
    been wandering if its anything todo with the coil pack?
    #3

Share This Page