1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A3 Speedo/Fuel gauge issues

Discussion in 'A3/S3 Forum (8L Chassis)' started by 1animal1, Aug 9, 2010.

  1. 1animal1
    Offline

    1animal1 The Clar!! it mouves!!! VCDS Map User

    Joined:
    Dec 27, 2007
    Messages:
    9,978
    Likes Received:
    32
    [Aug 13, 2010]
    cheers v12.....good luck with yours fella...only reason i havent gone down the normal route is because the speedo issue appeared almost at the same time making me think theres sumat else amiss.....hopefully it wont do it again

    Tim
    #41
  2. Dane
    Offline

    Dane Faster than a V12 Q7

    Joined:
    Nov 11, 2009
    Messages:
    4,016
    Likes Received:
    93
    [Aug 25, 2010]
    In an effort to not dilute information across different threads, here are my results from my speedo and fuel gauge not working.

    Back ground:
    I had to replace my gearbox as second gear kept popping out after my clutch pedal snapped.
    In an effort to fix the problem quickly I brought a second hand gearbox on 50K.
    After driving for about 25 miles the speedo went dead, the fuel gauge wouldn't sustain and the oil level sensor showed up on the DIS as faulty. The car drove fine and the oil level was well within acceptable limits.

    Action taken:
    The car was returned to the garage where the gear box change was done. The car was scanned and an inplausable signal from the vehicle speed sensor showed up (that cleared) and an unclearable code of short from oil level sensor. The fact that the two problems presented themselves at the same time indicated that there was an underlaying electrical problem.

    The Vehicle speed sensor was swapped out for the one in the old box, this made no difference. Out of interest the Vechicle Speed Sensor (VSS) from the second hand box was taken apart and suprise suprise it had been bodged shut with loads of Silicone. So a new VSS and oil level sensor were ordered and the car was back in the garage in two days time.

    When changing the VSS for the new one the mechanic at the garage noticed that there was a small strip of bare wire from the reverse switch. This switch is the the one that came with the second hand box so it was swapped out for the one in the old box the fuses were then checked (probably should've done this sooner) and the one described in the mkiv's link above had blown. This was replaced and in conjuction with swapping out the reverse switch for the one in the old box all returned to normal. The mechanic noticed the problem after he had replaced the new VSS so whether the old one still worked I don't know. All of the fault codes are now cleared.

    Obviously there are differences in my experience compared to animal's and others that i have read, but the slight portion of wire (2mm) that was exposed from the reverse switch was enough to trip the circuit and knock out some of the dash readings.
    #42
  3. 1animal1
    Offline

    1animal1 The Clar!! it mouves!!! VCDS Map User

    Joined:
    Dec 27, 2007
    Messages:
    9,978
    Likes Received:
    32
    [Aug 26, 2010]
    thanks Dane that is very helpful, after reading loads of threads it appears wiring is the common solution.....im finding/preferring to chase the faults from other people before i start to change hardware...no issues recently though, just the DIS seems a bit out maybe
    #43
  4. zseth
    Offline

    zseth Member

    Joined:
    Jul 2, 2010
    Messages:
    95
    Likes Received:
    0
    [Aug 26, 2010]
    i believe my fuel guage on the dash is giving an incorrect reading as after filling up half a tank, going home parking up then starting the next morning it only shows quarter tank?

    what do you guys suggest as a first step?

    thanks
    #44
  5. 1animal1
    Offline

    1animal1 The Clar!! it mouves!!! VCDS Map User

    Joined:
    Dec 27, 2007
    Messages:
    9,978
    Likes Received:
    32
    [Aug 26, 2010]
    hmmmm unsure as my S3 seems to have two points, either halfway or quarter, rarely inbetween........
    #45
  6. fingermouse
    Offline

    fingermouse thats me

    Joined:
    Sep 6, 2004
    Messages:
    3,771
    Likes Received:
    13
    [Aug 28, 2010]
    ok first how to get the pipes off

    push the clip
    [​IMG]
    like so
    [​IMG]

    so then this is the inside of the tank do you have to undo the 4 torx screws to remove the fuel guage sender ??? to clean it ????
    [​IMG]
    #46
  7. 1animal1
    Offline

    1animal1 The Clar!! it mouves!!! VCDS Map User

    Joined:
    Dec 27, 2007
    Messages:
    9,978
    Likes Received:
    32
    [Aug 28, 2010]
    awaits Finesse...where is he when you need him!!

    Finger....touch wood ive used her A3 all week without any issues, only thing ive really done is remove the battery and sand the 3 earth points - then rebolt them back down
    #47

Share This Page