1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A3 (8p) re-code for trailer wiring module

ScottTDI Dec 16, 2006

  1. ScottTDI

    ScottTDI Member

    83
    10
    8
    Hello,I have just fitted a dedicated wiring kit to a 2004 A3 complete with control module.All the lighting functions work correctly:happy:
    However,Vag com shows an error fault of "Control unit incorrectly coded".(on 19. Can gateway):uhm:
    I have a long coding of 3DOFOB40070101.
    I tried long code helper,but trailer funtion doesn't appear.
    Can anybody help?
    Regards,ScottB
     
  2. Uwe@Ross-Tech

    Uwe@Ross-Tech Member

    130
    0
    18
    What version of VAG-COM are you using?

    I have no problem finding Trailer in that coding. Byte 2, Bit 6.

    When you first start the Long Coding Helper, it only shows you the stuff in Byte 0. To see the stuff in the other bytes, you have to click the other bytes. The current byte will be yellow, all the others green.

    -Uwe-
     
  3. BrianM

    BrianM BrianM

    150
    0
    16
    Hi ScottB, don't mean to hi jack your thread but can you tell me what parts are needed for the wiring as I bought and fitted a used (Ebay) Audi towbar to my car and it came with a Westfalia control unit but nothing else and I think something is missing for the wiring. Any pics or instruction manual would be appreciated. Email or Pm if you prefer. Thanks in anticipation.
     
  4. ScottTDI

    ScottTDI Member

    83
    10
    8
    Hello Uwe,I'm using version 607.2, I did not know you could cycle through the bytes.Will try tomorrow and report how I get get on.
    ScottB
     
  5. Sebastian

    Sebastian Member

    286
    0
    16
    Look at this picture, see where it says "3)"? This is where you can select the individual bytes. :)

    [​IMG]

    P.S.: Scott, would you mind helping us to put up a trailer retrofit instructions like we did for other models?

    http://wiki.ross-tech.com/index.php/Retrofitting
     
  6. ScottTDI

    ScottTDI Member

    83
    10
    8
    Cheers Uwe, re-coded this morning,fault cleared.However I still have one more fault- 0047 - combination comfort databus single circuit
    012 - open circuit - intermittent

    I think this is caused when I patched into the CAN-BUS wires,will consult
    wiring kit manufactures tomorrow.
    Regards
    ScottB
     

Share This Page