1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A3 2.0 TDI temp sensor replacement (fans staying on)

Discussion in 'A3/S3/Sportback (8P Chassis)' started by gizm0, Sep 28, 2013.

  1. gizm0
    Offline

    gizm0 Member

    Joined:
    Apr 4, 2010
    Messages:
    182
    Likes Received:
    0
    Hi all, having a problem with my girlfriend 2.0TDI 140 A3, the fans are staying on when the engine is running. last time it did this i think i replaced a coolant sensor on the right hand side of the engine near the air box? i know i didnt have to replace the fans or anything. iv had a look through as many old threads as i can find but still cant find the part No for the sensor. Is anyone able to point me in the right direction of it?

    Thanks

    Dan
    #1
  2. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,228
    Likes Received:
    1,220
    There are 2 sensors on the bkd engine, possibly other engine codes aswell, 1 on the side like you've done & 1 hidden in the front in between coolant hoses to the left of the IMF.
    #2
  3. Chillout
    Offline

    Chillout Member

    Joined:
    Apr 4, 2013
    Messages:
    596
    Likes Received:
    48
    Scan it as it could be the fans at fault I think the control module is integrated into one of the fans.
    #3
  4. themikeyboosh
    Offline

    themikeyboosh Member

    Joined:
    Jun 9, 2010
    Messages:
    65
    Likes Received:
    0
    I had a similar problem, my fan wouldn't cut out even with the engine off! The only way it would stop was to disconnect the battery or the plug on the fan module. Anyway, it happened few times, the first few times were solved by topping up the coolant. The last time I had to replace the whole fan unit. Cost me about £70 from ebay and about £30 for someone to fit it.
    #4

Share This Page