1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A3 2.0 TDI Juddering HELP PLEASE

Discussion in 'A3/S3/Sportback (8P Chassis)' started by nick4575, Apr 28, 2013.

  1. nick4575
    Offline

    nick4575 New Member

    Joined:
    Feb 8, 2013
    Messages:
    5
    Likes Received:
    0
    [Apr 28, 2013]
    Hello i wonder if anybody come give me some advice please.
    I have a 2.0 TDI A3 2004 156000 and it has started to judder like mad and some times cuts out.
    When the accelerator pedal is pushed down hard i coughs and splutters but if you lift of for a split second it goes off.
    I have removed and cleaned the EGR and anti judder valves and have this morning replaced the diesel filter and it is still doing it but since i have changed the filter i have noticed the tick over is erratic..
    I am stuck and hopefully somebody will have an idea to what it could be so any ideas please.
    Nick
    #1
  2. Ads

    Ads

    [Oct 2, 2014]

  3. JimC64
    Offline

    JimC64 Active Member

    Joined:
    Apr 22, 2009
    Messages:
    244
    Likes Received:
    28
    [Apr 29, 2013]
    Could it be a problem with fuel delivery?

    I've had similar ish issues, usually when a low speeds / low revs then asking for a little more power and you get a violent judder?

    Mines was much better after replacing the fuel filter recently.

    Going into Audi on Wednesday for a new tandem pump ( failing - oil in filter ) in tank lift pump and injector seals.

    You could have a boost leak, intercooler issues etc etc......any codes?

    Mine has now and otherwise drives fine
    #2
  4. nick4575
    Offline

    nick4575 New Member

    Joined:
    Feb 8, 2013
    Messages:
    5
    Likes Received:
    0
    [Apr 29, 2013]
    Thanks for the reply been to an Audi/VW garage this morning and he said tandem pump oil seal most likley cause so taking it in Friday morning...
    #3
  5. s3reptdi
    Offline

    s3reptdi Member

    Joined:
    Apr 21, 2013
    Messages:
    172
    Likes Received:
    2
    [Apr 29, 2013]
    I had this and it was the injector wiring harness, been fine since
    #4
  6. nick4575
    Offline

    nick4575 New Member

    Joined:
    Feb 8, 2013
    Messages:
    5
    Likes Received:
    0
    [May 4, 2013]
    Finally know what the fault is thankgod..Inners of fuel tank flaking away and gone into the fuel pump..
    Took pump out of the tank and it was swimming with flaking fragments..
    So now i know what i need new tank and pump..
    #5

Share This Page