1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

a list of things needed to be sorted out, help needed

Discussion in 'A3/S3 Forum (8L Chassis)' started by fema||, Feb 1, 2014.

  1. fema||
    Offline

    fema|| New Member

    Joined:
    Sep 4, 2013
    Messages:
    14
    Likes Received:
    0
    Hi all...
    went for my MOT and got a list of problems:

    rear handbrake on the right side doesn't work, located the fault on the part where the wire comes to be stuck on the down position, hammered it back up but seems to want to get back down every time I pull the lever.the caliper probably just needs to be cleaned.

    The second is that my right side headlight shows straight to the ground, have tried to fix, not due to faulty clips. the adjustment Motor runs but doesn't want to lift the light up, sometimes maybe for a minute or so.

    thirdly my lamda-values were off, my O2 level was at 1.52 which is too much. a leakage on the intake somewhere? how to start searching for the fault?

    Today was the grand finale when i tried if my 4wd system worked and ended up stuck on the snow just to see the haldex isn't working, great... the fuse and the cables of the controller are okay, couldn't locate the ground wire though, is it on the top? the MOT fault-code scan didn't show any fault codes at all. i heard that the haldex goes off when you pull the handbrake, is it possible that haldex thinks it's on while it's not?

    is there light on the end of this tunnel? i feel fustrated:aggressive:
    #1
  2. rupe
    Online

    rupe A3 TQS

    Joined:
    Jul 14, 2013
    Messages:
    180
    Likes Received:
    2
    The headlight adjustment might be running, but have you run it with it out of the headlight to see if it's actually moving?

    Need a proper scan using vcds or similar, generic code readers won't read all the faults properly if they read them at all, you can also run a few tests on the haldex system with it too.

    Haldex issue could be a few different things, ground wire is on top of the diff and bolted to the floor pan above, not all had them though (mine doesn't) the connector at the rear of the diff, take it a apart and look for signs of corrosion or if you have oil in it, it could quite possibly be the pre charge pump has failed which is a common fault.

    http://www.audi-sport.net/vb/a3-s3-forum-8l-chassis/142194-haldex-not-working-no-communication-etc-look-inside.html
    #2
  3. fema||
    Offline

    fema|| New Member

    Joined:
    Sep 4, 2013
    Messages:
    14
    Likes Received:
    0
    Thank you for the answer.

    I haven't tried it being off, but the headlight actually moves a bit but doesn't stay up, or sometimes even get up at all, just tries to. I even tried to take the motor connector off but the manual height control didn't work. Could it be that what needs to be fixed?

    I saw a braided wire, is that the ground wire? I gently tried it with my hands but it seemed to be okay, not 100% sure though. I took the connector at the rear with the cover plate off, but there wasn't any corrosion, cleaned it anyways. Gotta get more into it.
    #3
  4. fema||
    Offline

    fema|| New Member

    Joined:
    Sep 4, 2013
    Messages:
    14
    Likes Received:
    0
    Wow i actually didn't find the ground wire, because there weren't one. Wth. Why would that be i have no clue. Made a new one but awd still not working. I was sure it was just it. Maybe i just need to buy new oils/filter and take a look at the haldex pump. After 6months of owning all these faults inside just a week. Such amaze.
    #4
  5. rupe
    Online

    rupe A3 TQS

    Joined:
    Jul 14, 2013
    Messages:
    180
    Likes Received:
    2
    Like I said not all had the earth strap, mine didn't and I can see the stud covered in the underbody stuff. Check out the vcds map and see if theirs anyone local too you that can plug it in and do a proper fault scan, you can also manually run the pump and operate the haldex controller too using the output tests.
    #5
  6. fema||
    Offline

    fema|| New Member

    Joined:
    Sep 4, 2013
    Messages:
    14
    Likes Received:
    0
    well, now mine has the earth strap... :D Why some would have it and some not if it's not neccessary? i'm going to read the codes in a few days and just today bought haldex oil and filter from a local VW dealer closing sale. If it's the pump, i'll buy a volvo pump and just change the parts from that one since its half the price.
    #6
  7. rupe
    Online

    rupe A3 TQS

    Joined:
    Jul 14, 2013
    Messages:
    180
    Likes Received:
    2
    If it does turn out to be your pump, you can buy just the motor and seals on their own, it's quite straight forward to strip the pump down.

    Still expensive for what it is really, but is still cheaper than the whole pump from audi at £400.

    HALDEX GEN1 PRE CHARGE PUMP MOTOR | eBay
    #7
  8. fema||
    Offline

    fema|| New Member

    Joined:
    Sep 4, 2013
    Messages:
    14
    Likes Received:
    0
    wow thanks for the link thats even cheaper than the volvo one. I just hope he ships to Finland. the pump from audi is here like over 600€
    #8
  9. fema||
    Offline

    fema|| New Member

    Joined:
    Sep 4, 2013
    Messages:
    14
    Likes Received:
    0
    did a full vtcs scan today, nothing on the lights, nothing on the lambda (exhaust leakage??), when we got to haldex,: 00526 brake switch fault, took it away and didn't show again. and then 01155 clutch malfunction, that would be the pump, right? have to buy a new motor i guess. i hope the controller isn't broken, or i'm ****ed.
    Last edited: Feb 5, 2014
    #9
  10. fema||
    Offline

    fema|| New Member

    Joined:
    Sep 4, 2013
    Messages:
    14
    Likes Received:
    0
    changed the oil and the filter of the haldex, cleaned and renewed the seals but still nothing at the back. the motor ran when i tested it. maybe the brake switch is the answer.

    Any thoughts?
    #10
  11. rupe
    Online

    rupe A3 TQS

    Joined:
    Jul 14, 2013
    Messages:
    180
    Likes Received:
    2
    Good news the pump is running :icon_thumright:
    A faulty brake switch can stop the haldex working, nice cheap fix if it is that :)
    #11
  12. fema||
    Offline

    fema|| New Member

    Joined:
    Sep 4, 2013
    Messages:
    14
    Likes Received:
    0
    Changed the brake switch, didn't ger awd. ****.
    #12

Share This Page