1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

99 1.8T keeps dying!

Discussion in 'A3/S3 Forum (8L Chassis)' started by Turbo Monkey, Oct 12, 2008.

  1. Turbo Monkey
    Offline

    Turbo Monkey New Member

    Joined:
    May 1, 2008
    Messages:
    12
    Likes Received:
    0
    Please help!

    Every time I stop at a set of lights or anything where I take my foot off the gas, my car just stalls, and the battery light comes on. It restarts fine, and continues until the next set of lights/junction.

    Any ideas?

    I'm thinking air filter. Any help would be great!?
    #1
  2. Clach
    Offline

    Clach A3 - 1.8Ts

    Joined:
    Jul 11, 2007
    Messages:
    971
    Likes Received:
    0
    that sounds air related to me...Maf?
    #2
  3. Turbo Monkey
    Offline

    Turbo Monkey New Member

    Joined:
    May 1, 2008
    Messages:
    12
    Likes Received:
    0
    Thats kind of what I'm thinking, although I'm hoping it is an air filter prob. This happens with the Mrs's Polo 6n, which has a general/common fault around the air filter/throttle body.
    #3
  4. Clach
    Offline

    Clach A3 - 1.8Ts

    Joined:
    Jul 11, 2007
    Messages:
    971
    Likes Received:
    0
    look for codes
    #4
  5. HTC
    Offline

    HTC Active Member

    Joined:
    Jan 11, 2004
    Messages:
    3,413
    Likes Received:
    0
    Bad MAF or air filter won't cause this. I would say you've got a problem with your throttle body or a bad vacuum leak. Most likely the former.

    Throttle switch to tell the ECU is in idle or WOT state is in there. Also stepper motor for idle stability is in there. Check the cable to it first, but as Clach says, you should see some error codes relating to the throttle body. If not, then it may be a vacuum leak, but that would usually cause a lumpy idle.
    #5
  6. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    30
    I had this on my A4 and eventually turned out to be the water pump stalling the engine as it was on its way to seizing up. Luckily it was leaking slightly so I got it changed because of that (as Audi didn't change it when they did the timing belt, tossers), and it cured the problem. When we removed it, it was so tight you could not turn it by hand at all. It's a long shot but worth considering if all the more likely causes don't sort it and it wasn't changed with the timing belt.
    #6
  7. Turbo Monkey
    Offline

    Turbo Monkey New Member

    Joined:
    May 1, 2008
    Messages:
    12
    Likes Received:
    0
    Forgot to mention, I've just changed the battery, as the old one wasn't holding a charge. Could this have anything to do with it? It was fine before, except for the battery not holding a charge for long.
    #7
  8. HTC
    Offline

    HTC Active Member

    Joined:
    Jan 11, 2004
    Messages:
    3,413
    Likes Received:
    0
    Ahh, you might well need to perform a throttle re-alignment if you'd had the battery off. Especially if it was fine before.

    Performed, yes you've guessed it, through vag-com for DBW cars. Self aligning for non-DBW cars if you switch on the ignition and don't start the engine, don't touch the throttle pedal and wait for the sound from the throttle body to stop (about 20-30 seconds).
    #8

Share This Page