1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

8P Regular warning lights - ABS / Traction Control / Headlight range defective - HELP

Discussion in 'A3/S3/Sportback (8P Chassis)' started by eeeyann, Aug 28, 2011.

  1. eeeyann
    Offline

    eeeyann New Member

    Joined:
    Jun 21, 2011
    Messages:
    3
    Likes Received:
    0
    [Aug 28, 2011]
    Hello,

    I've got a 2004 2.0 TDI 140.

    Just been getting three warning lights, illuminating at the same time and ONLY once I have passed 65-70mph for roughly TEN seconds. The lights will not come on if I make a small, slow trip - and the car is mechanically smooth, nothing noticeable.

    The lights are the ABS, Traction control and on the centre display a "HEADLIGHT RANGE CONTROL DEFECTIVE" light - not even sure what that means, or if i have range control.

    ANYWAY - the peculiar thing is, 2 months ago my ECU was water-damaged and I was getting sporadic and irregular warning lights as things were shorting, there was no abs light at this time but the Traction and the Headlight range lights would come on, but the behaviour was entirely different.

    The ECU was replaced by Audi to the tune of 839 quid, so it's still under warranty. I was just posting to ask if anything similar had happened to anybody else, and what it could be?

    Car is mechanically operating perfectly, and when the ECU was damaged before the car was running fine as well. I think perhaps this could be another electrical fault.

    Thanks!
    #1
  2. Ads

    Ads

    [Sep 21, 2014]

  3. penoll
    Offline

    penoll New Member

    Joined:
    Sep 15, 2011
    Messages:
    2
    Likes Received:
    0
    [Sep 15, 2011]
    Hi,
    I have a 2005 Sportback 2.0 TDI 140

    Yesterday the same thing happened to me, but it happened after driving for about 5 minutes in city speeds. Before this the "lamp broken" light has been turned on now and then for several months. Now this light is always on and the lamp is off (broken ? I have time at the garage next week).

    Strange thing is that today, only the "lamp broken" light was on. The other three didn't come on !

    What is going on ? Did you get an explanation ?
    #2
  4. penoll
    Offline

    penoll New Member

    Joined:
    Sep 15, 2011
    Messages:
    2
    Likes Received:
    0
    [Oct 30, 2011]
    The cause of all lights (except for "lamp broken" ) coming on was a bad rotation sensor at left rear wheel. Changing sensor and wheel bearing took care of it.
    #3
  5. eeeyann
    Offline

    eeeyann New Member

    Joined:
    Jun 21, 2011
    Messages:
    3
    Likes Received:
    0
    [Nov 17, 2011]
    Yes! Wheel bearing was what it was!
    #4
  6. pit76
    Offline

    pit76 New Member

    Joined:
    Mar 8, 2007
    Messages:
    3
    Likes Received:
    0
    [Aug 19, 2013]

    Ok I just have exactly the same problem on my 05 A3 3.2 Sportback.

    ABS,TC, and headlight range defective just came up. Also comes on all together when driving over 70mph.

    After turning car off and starting again all goes away until next time - any idea?

    How wheel bearing got something to do with the head lights range?? wheel sensor makes sense for ABS and TC lights but headlights range control?

    Please help!
    #5

Share This Page