1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

55plate 2.0tdi a6 loosing power, help???

benny-g Nov 22, 2009

  1. benny-g

    benny-g New Member

    18
    0
    1
    Looking for some advice, its a 55plate a6 2.0tdi 140bhp with 70k on the clock and there seems to be a problem with the turbo, thats what i think anyway. Just driving normally and all of a sudden the car just seemed to have lost all performance, unwilling to accelerate and struggling to get above 40mph to have dissapeared ending up with huge loss of power and really struggling to accelerate at all. The emissions warning light also came on when this all happened.

    Does anyone have any idea of what might be causing this, is it a dead turbo or just a faulty sensor? Any advice would be appreciated.

    Thanks in advance,

    Ben
     
  2. den

    den New Member

    6
    0
    1
    i had similar problems and it was faulty EGR valve
     
  3. oldskool rich

    oldskool rich New Member

    6
    0
    1
    yep im saying EGR, common fault
     
  4. Bobtech

    Bobtech New Member

    20
    0
    1
    Could well be the MAF, a very common fault on loads of petrol and diesel vehicles. I think this model has a MAF anyway. The MAF made by Bosch, falls over at anything around the 60,000 - 80,000 mark very commonly.

    Having said all that, yes the EGR valve affects performance big time.

    To be safe, get the ECU scanned to see what has bought the check light on and that should point you in the right direction.
     

Share This Page