1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2006 A4 Cab Rear top roof cover closing slowly????

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by Phil_Cool, Apr 8, 2013.

  1. Phil_Cool
    Offline

    Phil_Cool New Member

    Joined:
    Jan 13, 2013
    Messages:
    7
    Likes Received:
    0
    [Apr 8, 2013]
    Can anyone help?

    Three times this past weekend I've gone to open the roof, windows drop, roof opens, top cover raises normally, roof goes back as it should but then top cover lowers slowly as if its not under hydraulic pressure but falling under its own weight, it gets to about 3" from closing and the cycle stops.

    On two occasions I've released the roof button momentarily and tried again and it's worked, the roof top cover locks, however on one occasion it didn't and I had to reset the roof by closing manually.

    anyone else had this problem? All comments appreciated! Cheers!
    #1
  2. Ads

    Ads

    [Oct 20, 2014]

  3. jjmurphy21187
    Offline

    jjmurphy21187 Tiptronic

    Joined:
    Jun 21, 2010
    Messages:
    872
    Likes Received:
    44
    [Apr 9, 2013]
    #2
  4. MGTURBOM
    Offline

    MGTURBOM Member

    Joined:
    Oct 29, 2006
    Messages:
    78
    Likes Received:
    1
    [Apr 10, 2013]
    Sounds like the brushes in the motor. I've have the same problem with mine. Haven't got round to cleaning the motor yet so the rear panel is still out in the boot and a rubber mallet is used when it sticks!
    #3
  5. VagPro
    Offline

    VagPro Active Member

    Joined:
    Feb 10, 2011
    Messages:
    379
    Likes Received:
    27
    [May 8, 2013]
    Have you got your roof issue resolved yet? Let me know if you need any support
    #4

Share This Page