1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2004 A6 Avant - Central locking anomalie

Discussion in 'A6/S6/Allroad forum (C5 Chassis)' started by Des Nutting, Nov 9, 2011.

  1. Des Nutting
    Offline

    Des Nutting New Member

    Joined:
    Nov 9, 2011
    Messages:
    1
    Likes Received:
    0
    HI,

    I hope someone can help!:search:

    My key fobs stopped working about 6 weeks ago, changing the battery did not solve the problem, nor did the attempts to recode them. The door lock (all doors) also appears to not work correctly, in that it locks the doors but doesn't unlock them.

    If I lock the car from the drivers door, it only locks the drivers door and not the rest. If I lock the car from the boot, it locks all doors and sets the alarm.

    Once done, if I open the car from the drivers door, the alarm goes off, unless I get the key in the ignition in time. If I unlock the car from the boot, only the boot opens and again, the alarm goes off.
    I have tries a new CCU, with the same results :wtf:

    The key opens the drivers door fine and starts the car with out issue.

    I have checked all fuses, and don't seem to have the familiar problem of water seeping into the passenger footwell and flooding the CCU.

    Please guys - Help!

    Regards
    Des
    #1
  2. Watty
    Offline

    Watty ..... (_!_) Sarah's A3s #1 Fan

    Joined:
    Sep 8, 2007
    Messages:
    404
    Likes Received:
    0
    Hi there,

    When you say you tried another control module, I take it you took your own out of the black plastic box, in the footwell. Was it dry? Were the connectors corroded at all? I had water in mine and had to clean up the pins/ connectors.
    #2
  3. Daveanderby
    Offline

    Daveanderby New Member

    Joined:
    Apr 28, 2011
    Messages:
    4
    Likes Received:
    0
    Hi Des,

    How did you get on?

    Mine has exactly the same problem.

    The central locking button will lock all doors but not open them.

    The remote fob does nothing.

    People keep talking about the control unit in the passenger foortwell - I've tried lifting the carpet but with little joy.

    Not the fuse.

    Any help would be greatly appreciated.

    Cheers

    Dave
    #3
  4. Daveanderby
    Offline

    Daveanderby New Member

    Joined:
    Apr 28, 2011
    Messages:
    4
    Likes Received:
    0
    Okay, I've checcked the CCU inthe black box in the footweel (thanks Watty), this is bone dry, all connectors look good to me.

    I've unplugged all the connectors and plugged them back in again for good measure, but this made no difference.

    This fault has happened a couple of times in the past, but only for a day, so this makes me think it is a connector issue somewhere.

    As the doors won't unlock from the button on the drivers door, I don't think it's a problem with the remote sensor.

    I considered trying to disconnect the alarm siren so at least my neighbours will not get fed up of my alarm going pff at 7am, but this seems to be as difficult as trying to resolve the actual problem.

    Any auti-electricians out there?
    #4

Share This Page