1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2004 A3 2.0 tdi problems and fault codes

Discussion in 'A3/S3/Sportback (8P Chassis)' started by gizm0, Oct 16, 2013.

  1. gizm0
    Offline

    gizm0 Member

    Joined:
    Apr 4, 2010
    Messages:
    187
    Likes Received:
    0
    [Oct 16, 2013]
    Hi all, having a few issues with my girlfriends 2004 A3 2.0 tdi. Firstly the radiator fan keeps coming on really soon after starting, I have replaced the coolant stat as that's what it was before when it happened. But still have the same problem. Also last night after 20 minutes of motorway driving the coil light started flashing on the dash and it went into limp mode with no power at all. When I got home I turned the engine off and back on again and it stopped. Today to be safe I got the car scanned for faults and it came back with the following codes: 18359 coolant fan, 18358 coolant fan, 16610 throttle position sensor. Iv had a quick look on here but can't make sense of what it could be as there seems to be so many different opinions. Any help would be greatly appreciated.

    Thanks

    Dan
    #1
  2. Ads

    Ads

    [Sep 30, 2014]

  3. SAiLO
    Offline

    SAiLO Enthusiast VCDS Map User

    Joined:
    May 7, 2009
    Messages:
    938
    Likes Received:
    33
    [Oct 17, 2013]
    Throttle position sensor code would indicate a problem with your accelerator pedal sensors.
    Have a look on Ross-Tech wiki for more info.
    #2
  4. gizm0
    Offline

    gizm0 Member

    Joined:
    Apr 4, 2010
    Messages:
    187
    Likes Received:
    0
    [Oct 17, 2013]
    Ok that's great thanks, will have a look!
    #3
  5. gizm0
    Offline

    gizm0 Member

    Joined:
    Apr 4, 2010
    Messages:
    187
    Likes Received:
    0
    [Oct 17, 2013]
    Ross-tech only lists one of the fan fault codes and says it could be jammed but it spins freely and nothing in there. Iv seen something about replacing a fan but unsure which it is that needs replacing, but also seen that some have had to replace a control unit or something on them? Would any of these codes mean that one of them needs doing?

    The throttle code apparently could mean a number of things like O2 sensors but I will get the car scanned again tomorrow to see if anything else has re appeared. The car also has warm starting trouble and lumpy idle but not sure if that could be linked to these issues?
    #4
  6. gizm0
    Offline

    gizm0 Member

    Joined:
    Apr 4, 2010
    Messages:
    187
    Likes Received:
    0
    [Oct 20, 2013]
    ok so just checked the car for sault codes again, only the fan one is coming up (18359) with the ignition on there is a constant whining type sound coming from the fan area. is this normal?

    thanks!
    #5
  7. gizm0
    Offline

    gizm0 Member

    Joined:
    Apr 4, 2010
    Messages:
    187
    Likes Received:
    0
    [Oct 22, 2013]
    Overwhelming response on here lol
    #6
  8. @udi A3
    Offline

    @udi A3 Site Sponsor Site Sponsor VCDS Map User

    Joined:
    May 25, 2012
    Messages:
    1,766
    Likes Received:
    175
    [Oct 22, 2013]
    whiring fans and o2 sensors. id be loooking at the o2 sensor and wiring, logging with vcds and hoping the ecu isnt fried.

    Where abouts are you?
    #7
  9. Lewis583
    Online

    Lewis583 Active Member VCDS Map User

    Joined:
    Mar 15, 2010
    Messages:
    884
    Likes Received:
    70
    [Oct 22, 2013]
    Diesels don't have 02 sensors. At least the BKD doesn't.

    You need to log the throttle position sensor with ignition on engine off. Watch the measuring blocks as you SLOWLY depress the accelerator pedal. Look for any abnormal/erratic readings.

    You may find that you have one reading that the % increases as you press the pedal and you have one that decreases % as you press the pedal. This is a fail safe that the ECU uses to asses plausibility of the pedal position sensors and is normal.
    #8
  10. gizm0
    Offline

    gizm0 Member

    Joined:
    Apr 4, 2010
    Messages:
    187
    Likes Received:
    0
    [Dec 5, 2013]
    Sorry guys missed these replies. I'm still having issues however it went away but came back yesterday :( it has got worse and I'm loosing power immediately after changing gear. I live near Birmingham
    #9

Share This Page