1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2004 3.2 DSG engine stalled ESP light on

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Marcosline, Apr 28, 2010.

  1. Marcosline
    Offline

    Marcosline Petrol Feet

    Joined:
    Oct 1, 2009
    Messages:
    9
    Likes Received:
    0
    Hi, all with the 3.2s just wondering if any of you have experienced this, when driving from the south coast to North Wales yesterday while in busy traffic at about 20 mph the engine on my 3.2 DSG cut out , this was in the outside lane of the motorway ,i looked at the dash to see all the usual lights on as though you were about to start the engine from cold ,so i quickly poped it into neutral and she fired up straight away but the ESP light stayed on with no running issues or anything, the next place we stopped was at Warwick services, on returning to the car and starting it up the ESP light has stayed off and has not re appeared after a further 400 miles of driving.Just a little curious/ concerned as to why the engine would shut down if its a ESP sensor by one of the wheels dirty or failing. Any feedback would be appreciated, thank you Marc :confused:
    #1
  2. Hellz
    Offline

    Hellz Geordie Racer

    Joined:
    Apr 15, 2009
    Messages:
    372
    Likes Received:
    6
    I had this issue a good while back without ever really pinpointing the root cause - a few others experienced similar issues. Ever since i had an ECU factory reset by AUDI its been fine however, judging the year your 3.2 was built it may be better going for the latest update which resolves another 3.2 issue - engine hesitancy.

    see the following threads for more info:

    Engine cutting out - http://www.audi-sport.net/vb/showthread.php?72043-Engine-cut-out-ECS-ESP-lights-on

    ECU update to resolve hesitancy issue - http://www.audi-sport.net/vb/showthread.php?78089-Help-needed!-3-2Q-DSG-Hesitant-engine-~-2k-rpm
    #2
  3. Marcosline
    Offline

    Marcosline Petrol Feet

    Joined:
    Oct 1, 2009
    Messages:
    9
    Likes Received:
    0
    Cheers for the reply Hellz, the problems your car was giving sound exactly the same as mine, i have been following the thread about the 2000rpm issues and mine does that to though not enough to notice while driving along, also it would appear that coil pack failure is common i experienced this a couple of years ago when she started misfiring, called the rac who diagnosed it as coil pack 5 failed it dawned on me then when the fitter had one in his van that this may be a comon problem and just to note that while i was driving last saturday to the main dealer for a long life service 70000 miles she started misfiring emissions light on , managed to limp to dealers where they serviced it and replaced coilpacks 3 and 5 this time they are a grey colour instead of black may be an updated version, its good to know that if the first issue happens again you can still drive the car, think i shall probably book it in next week for a check on the stalling / ESP light on problem. thanks again Marc.:icon_thumright:
    #3

Share This Page