1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2003 A4 Avant 1.9Tdi....engine problem

Discussion in 'A4/S4 forum(B5 Chassis)' started by dazpc627, Jan 2, 2012.

  1. dazpc627
    Offline

    dazpc627 New Member

    Joined:
    Jan 2, 2012
    Messages:
    2
    Likes Received:
    0
    [Jan 2, 2012]
    Can anyone help me with a problem that has just occured on my vehicle.......I have been experiencing my brake lights coming on once the car has been left left switched off and locked...mostly when its cold outside and at night???
    Then over the past two days whilst driving the ESP warning light comes on and shortly after that I have no accelorator.....if left the Glow plug light lights up flashing, however I turned the ignition key one 1/4 turn back and then forward again and the lights clear and I have normal driving capability?....this will happen randomly and depending on the length of journey may happen a few times then clear all together. Then engine still runs when I lose accelerator, which leads me to think this is an electrical problem, rather than mechanical.

    When I start the engine, it goes through the checks and all warning lights extinguish revealing no problems!!!

    Has anyone experienced this very strange and worring problem? if so what was the cause/fix?

    Rgds

    Daz
    #1
  2. Ads

    Ads

    [Dec 25, 2014]

  3. towcestervag
    Offline

    towcestervag Member VCDS Map User

    Joined:
    Jan 14, 2011
    Messages:
    165
    Likes Received:
    5
    [Jan 5, 2012]
    replace brake light switch
    #2

Share This Page