1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2002 audi cab fault codes help

bowmeat Jun 8, 2010

  1. bowmeat

    bowmeat New Member

    4
    0
    1
    hi all
    i have a 2002 audi cab and the other day i put the roof down with a suit case on the back seats, the roof touched the suitcase where it folds inside the rear seats then stoped its procedure, i had to then put it up manually . now when i go to put it down the windows just drop normally but the roof doesnt move i have done the manual reset in the handbook with no luck
    this evening i plugged it into my mates computer and got the following codes
    02000 - switched positon not a plausable signal
    01996 - cabrio top lock switch -f294 open not a plausable signal
    01995 - cabrio top lock switch -f295 closed not a plausable signal

    cleared the codes and roof still wont work and 2 of the codes have come back

    any ideas will be welcome
    thx shane
     
  2. GAudiTech

    GAudiTech Member

    113
    2
    16
    F294/295 are located at the front of the roof behind plastic trim. Not done one in a while but i believe both switches are built into the latch unit. These are just to allow the control unit to know the position of the latch. if it dosent know the position it wont work. If you have vagcom check measure value block 07 of roof electronics. If i remember right the value 1 is the readouts for them. Will possibly req replacing if not operating correctly
     
  3. bowmeat

    bowmeat New Member

    4
    0
    1
    thx mate , is they any way to tell if they have gone without replaceing
     
  4. GAudiTech

    GAudiTech Member

    113
    2
    16
    When operating the roof switch, watch the values in the measured value block to see if the switches are reading correctly. does the roof lock and unlock when operating the switch?. Try manually unlocking and lowering the roof to its open position, then operate the switch to close it.
     
  5. bowmeat

    bowmeat New Member

    4
    0
    1
    the roof doesnt open or close with the switch its gotta be done manually i have tryed lowering it manually then using the switch but no joy
     
  6. GAudiTech

    GAudiTech Member

    113
    2
    16
    Go to measured value block 1. On readout 2 will be the list of switch states in binary form (1 or 0). This reading should be 8 digits long (8 switches). The ones you need to pay attention to are the 5 and 6th ones from the left. The 5th one is the open position and the 6th one is the closed position. These should change when manually operating the lock from 0 to a 1. For instance, when unlocked it should look something like ( xxxx10xx) and closed (xxxx01xx). Don't pay attention to the other numbers just these. You need to do this to see if the switch is giving the correct position at the correct time. If it doesn't then it wont work the roof. Have fun!
     
  7. GAudiTech

    GAudiTech Member

    113
    2
    16
    Any luck?
     
  8. bowmeat

    bowmeat New Member

    4
    0
    1
    yes i sorted the problem by manually opening the roof then pulled the roof switch to the open position and turned on the ignition and kept the switch pulled for 20 seconds that set the open postion then closed thew roof manually pushed the button down turned on the ignition kept the button pushed for 20 seconds again to set the locked position

    this may help some of you guys out at one point
    thx shane
     
  9. shaid

    shaid New Member

    5
    0
    1
    Any help guys
    problem with my roof not closing. It opens all the way but when i try to close it it stalls with a few inches from locking. The roof light flashes on the dashboard:

    Did a full manual reset but to no avail. the roof goes down and the first time it closes ok. However, when you do this the second time the same thing happens and the roof light flashes on the dashboard.

    Plugged in the diag tool and it comes with these three errors. even if you reset them they reappear.

    02000 Switch position not a plausible signal
    01996 Cabrio top lock switch - F294 Open Not a plausible signal Intermittent
    02024 Perfom adaptation No or Wrong Adaptation


    PS: the near side latch that holds the sensors was replaced last week from Audi
     
  10. Sean3483

    Sean3483 New Member

    1
    0
    1
    Hi all,

    Im having an issue when closing the roof on my A4, basically it closes all the way with the electronic switch, but for some reason it doesn't register that it's closed. The windows don't roll up and then as you pull away it beeps and says soft top not secure!

    If I turn the ignition off and leave the car for an hour or so it seems to reset and it doesn't say "soft top not secure".

    Im guessing its something to do with the closing switch F295? But I'm not sure?

    any help would be much appreciated

    Sean
     
  11. shaid

    shaid New Member

    5
    0
    1
    Just bought a 57 reg 2.0 fsi convertible ..and guess what the bloody roofs not working...second cab i have had issues with over the last 4 mnths:
    With this one the roof opens a few inches, windows come down..ands thats it..doesnt go any further..from that position it closes ok as well..HAve tried the manual reset but to no avail...
    will get a vag tool on it tomorrow but any pointers will be appreciated..

    Ok i get these error codes:

    0199- switch for compartment cover locked
    03245 canopy position implausible
    0532- supply vlotage B+ lower limit
    02000- switch position not plauibsle
    01996-cabrio top lock switch
    F294

    Any idea guys?

    regards
     
    Last edited: Mar 6, 2013
  12. ShelleyMcGuinness

    ShelleyMcGuinness New Member

    1
    0
    1
    The instructions below worked really well, with one addition. The first time you go to open it, you may need to manually unlatch the roof-locks with the key. Once I did this, all working fine again.

    Another tip.... don't feel inclined to 'help it along' as it tries to open/close. The interlock circuits will detect this and stop the whole thing again.

    Therefore, the sequence I used was:-

    Manually put roof down (away in boot).
    Ignition on.
    Hold button to 'Roof Down' for 20secs.
    Ignition off.
    Manually put roof up.
    Ignition on.
    Hold button to 'Roof Up' for 20secs.
    Ignition off.
    Ignition on.
    Try to open roof, and use roof key to release roof if it doesn't release itself straight away.



     
  13. variosso

    variosso Vorsprung Durch Technik

    358
    65
    28
    I've got a very similar problem. I have a 2004 A4 Cab, the roof opens, the back cover goes up, stops at some point and falls back down leaning on the roof itself. I get the same fault code with VAG: 02000 Switch Position, 0800 Implausibe Signal. I tried resetting it manually - no luck. Readapting with VAG - no luck. The above method - no luck. Anything else I could try?
     
  14. AlexV

    AlexV New Member

    2
    0
    1
    Hi all,

    I have exactly the same codes as the OP on my 2003 A4 Cab, but the 'Roof Down' for 20secs, 'Roof Up' for 20secs method didn't work for me, so I'm trying to figure out if I did something wrong. I don't have easy access to VAG (the codes I got were from my mechanic) - do the error codes first need to be reset in VAG before doing the 20 secs method?
     
  15. AlexV

    AlexV New Member

    2
    0
    1
    Turns out I was doing something wrong - after completing the 20 secs sequence properly, the roof did try to open. However, in my case the top latches failed to disengage even though the motor produced some whirring sounds. I ended up disassembling the whole thing - turns out the two allen bolts that hold the motor assembly to its frame got loose over time (there was no thread compound on them at all) and that caused the splined shaft to spin freely. I tightened the bolts and everything works now (though the motor still seems to be making more sounds than it used to - I might have to disassemble it further to see if there's any damage).
     
  16. Allmine

    Allmine Member

    143
    13
    18
    I'm having the same problem with my 2002 A4 cab. Firstly the hood wouldn't open at all and found that the control module had burst out so replaced that and now it opens all the way into the boot but upon closing it gets stuck a few inches and doesn't latch itself back!! Another issue is that I can't manually reset it as the special key doesn't release the boot section for some reason and I'm getting an error code of 02000 switch position 088 implausible signal. Any help would be appreciated thanks
     

Share This Page