1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2000 X 1.9tdi AJM Engine Limp Mode / Lumpy / smokey / Poss Injector

Discussion in 'Diesel forum' started by alictait, Dec 29, 2010.

  1. alictait
    Offline

    alictait Member

    Joined:
    Dec 2, 2006
    Messages:
    46
    Likes Received:
    0
    [Dec 29, 2010]
    Hi - Posted this in the B5 thread but no response. Any help appreciated.

    Hi Guys,

    Getting fed up with my A4 B5 and now starting to think about replacing as more and more wee things start going wrong. It has done me 6 years mind you and owes me nothing now but still has been too good a car to me to dismiss now.

    Anyway latest is that last night whilst on a short drive I heard a bursting noise which I thought was a tyre blowing so stopped to change the tyre. When I got out of the car the tyres were fine. When I went to drive away I had no revs and the engine stalled. After reving pretty hard I managed to pull away and then get the car home.

    Now whilst idling the car revs to 1000 rpm and then drops to 800rpm and then back to 1000 rpm constantly and hisses at me when I rev to around 2500 rpm & above. Also when driving it seems to be in constant limp mode and is def. smokey (grey). There is also a smell in the cabin which I'm not sure if its diesel or oil. I have looked at my vacuum hoses and can't see any degradation. I replaced about half of them last year when I was having pressure / power issues (which rectified the problem then).

    I have connected it up to my third party diagnostics cable with VCDS-lite free version. I did initially get the 17964 - Charge Pressure Control: Negative Deviation (intermittent code) however after clearing the code this has gone.(this could be historic) There are no other fault codes registered and this error has not came back after a very brief run.

    Would I expect to get a fault code for a faulty injector ? Do you think it is likely to be a faulty injector ? Is there a way to check ?

    Thanks in advance for any help.

    Ali
    #1
  2. Ads

    Ads

    [Sep 30, 2014]

  3. anilkumar
    Offline

    anilkumar Member

    Joined:
    Jul 17, 2010
    Messages:
    66
    Likes Received:
    0
    [Jan 2, 2011]
    if it was an injector I'm sure you would get a code have you checked your intercooler pipe someone might be able to help you on ukmk4s foum its got some good infomation on it for tdis put a post on threre i have been useing it its quite usefull
    #2
  4. alictait
    Offline

    alictait Member

    Joined:
    Dec 2, 2006
    Messages:
    46
    Likes Received:
    0
    [Jan 9, 2011]
    Thanks for the help, I have been looking at stuff for the intercooler and my own thread came up. I got no notifications for your reply at all :(, even in my settings screen it doesn't show that I had a comment.

    Thanks though I will check out that forum.

    Ali
    #3
  5. alictait
    Offline

    alictait Member

    Joined:
    Dec 2, 2006
    Messages:
    46
    Likes Received:
    0
    [Jan 10, 2011]
    In about the engine today and the intercooler has split in two. Managed to get it out today and have ordered a replacement.

    Thanks again

    Ali
    #4
  6. alictait
    Offline

    alictait Member

    Joined:
    Dec 2, 2006
    Messages:
    46
    Likes Received:
    0
    [Jan 15, 2011]
    Intercooler replaced and car spot on again now. Tx for help
    #5

Share This Page