1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2000 Sport TDI - Limp Mode / Over Boost

Discussion in 'A3/S3 Forum (8L Chassis)' started by ruffrida, Feb 27, 2012.

  1. ruffrida
    Offline

    ruffrida Well-Known Member

    Joined:
    Feb 20, 2012
    Messages:
    1,603
    Likes Received:
    225
    [Mar 13, 2012]
    Follwoing on from the video posted by R Tech i will be strpping and cleaning the turbo this weekend, it seems my last option before buying a new one, and dont really want to spending a fortune as i want to upgrade to a 05 plate pretty soon...
    #41
  2. ruffrida
    Offline

    ruffrida Well-Known Member

    Joined:
    Feb 20, 2012
    Messages:
    1,603
    Likes Received:
    225
    [Mar 18, 2012]
    Well spent 5 hrs on it yesterday, and have come to the conclusion that the wastegate is knackered, you can wiggle the arm back and forth for so long then it sticks, that bad that you need a screw driver to prize it back open, i couldnt even get the bolts undone t look inside, as these went from a 10mm, to 9, to 8, to a circle, not fun.

    Built it all back up wnet for a drive an bang the oil feed pipe burst /snapped spraying the whole engines oil contents all over the engine bay, wha f***ing joy!!!
    #42
  3. ruffrida
    Offline

    ruffrida Well-Known Member

    Joined:
    Feb 20, 2012
    Messages:
    1,603
    Likes Received:
    225
    [Apr 26, 2012]
    Well after hours of Mr Muscle and a lot of pain in the arse, i have decided to get the turbo refurbed.
    The vanes had stuck that bad it was close to seizing, pretty lucky really as once it had been stripped the bearing was also on its way out.
    It is now with AC Turbos in Skelmersdale, £240 for a full refurb, lets hope this is it now.
    Thanks for all the advice guys will keep you informed,
    Cheers
    #43
  4. ruffrida
    Offline

    ruffrida Well-Known Member

    Joined:
    Feb 20, 2012
    Messages:
    1,603
    Likes Received:
    225
    [May 8, 2012]
    Right, we have now had a slight improvmnt, but not much.

    New Turbo,

    New N2

    All vacum hoses replaced

    Upgraded standard filter fitted,

    But guess what?
    Yep still goin into limp mode, you can hear a slight whislt sound coming from the engine bay and when it is stood running on tick over the revs are up and down and it sounds like wind blowing through a very small gap (high pitched whislt).

    This has been going on for months now and still not right, please pleae can some one help,

    Cheers
    #44
  5. pjgorton
    Offline

    pjgorton New Member

    Joined:
    Jul 12, 2013
    Messages:
    1
    Likes Received:
    0
    [Jul 12, 2013]
    I had the EXACT symptoms on my golf tdi, just before replacing the turbo we flipped the check valve, turns out the factory sent out a bunch of tdi's with checkvalves backwards that year. Fixed the problem in two seconds!
    #45

Share This Page