1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.5tdi won't rev above 3500rpm?!?

Discussion in 'A4/S4 forum(B5 Chassis)' started by pdf11, Jan 7, 2012.

  1. pdf11
    Offline

    pdf11 New Member

    Joined:
    Apr 30, 2011
    Messages:
    14
    Likes Received:
    0
    [Jan 7, 2012]
    hi.
    i have a 1999 2.5tdi a4 avant that wont rev above 3500rpm, and isn't that quick getting there. doesnt feel like its in any kind of limp mode, but its as if its 'limited'?. i've unclipped the maf sensor and still no difference. it starts and sounds smooth as it should.
    could anyone shed some light on this as i've run out of ideas
    cheers
    #1
  2. Ads

    Ads

    [Oct 21, 2014]

  3. Bradderz_1988
    Offline

    Bradderz_1988 Dont replace it, Upgrade it !!

    Joined:
    Aug 19, 2010
    Messages:
    3,287
    Likes Received:
    113
    [Jan 7, 2012]
    Try blocking off the EGR valve see how that helps it !
    #2
  4. Bradderz_1988
    Offline

    Bradderz_1988 Dont replace it, Upgrade it !!

    Joined:
    Aug 19, 2010
    Messages:
    3,287
    Likes Received:
    113
    [Jan 7, 2012]
    Also try cleaning the maf sensor with brake cleaner.
    #3
  5. pdf11
    Offline

    pdf11 New Member

    Joined:
    Apr 30, 2011
    Messages:
    14
    Likes Received:
    0
    [Jan 7, 2012]
    i've just seen a egr blanking plate on ebay, i'm ordering one and let you know
    thanks for the quick reply
    cheers
    #4
  6. PAULF
    Offline

    PAULF Active Member

    Joined:
    Jan 27, 2011
    Messages:
    651
    Likes Received:
    51
    [Jan 7, 2012]
    #5
  7. pdf11
    Offline

    pdf11 New Member

    Joined:
    Apr 30, 2011
    Messages:
    14
    Likes Received:
    0
    [Jan 10, 2012]
    Right.....cleaned maf sensor, de-coked turbo vanes with mr muscle, and blocked off egr valve. 1st and 2nd gear rev fine, but only to 3500rpm. 3rd - 6th still not quick, doesnt seem to be a limp mode just feels lazy getting there compared to 1st and 2nd, but still only revs to 3500, wont go past....running out of ideas as the engine runs sweet as a nut, starts fine, but at the moment its like theres a limiter on it?
    any help would be greatly appreciated....
    cheers
    #6
  8. PAULF
    Offline

    PAULF Active Member

    Joined:
    Jan 27, 2011
    Messages:
    651
    Likes Received:
    51
    [Jan 10, 2012]
    How about looking for air bubbles in the clear fuel line?
    The fuel filter can leak air at the tee-piece, which would be worse under high revs.
    #7
  9. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,697
    Likes Received:
    331
    [Jan 10, 2012]
    Does it rev past 3500rpm in neutral?
    #8
  10. pdf11
    Offline

    pdf11 New Member

    Joined:
    Apr 30, 2011
    Messages:
    14
    Likes Received:
    0
    [Jan 10, 2012]
    thanks for the replys. i'll try both suggestions tomorrow....keep you posted
    cheers
    #9
  11. pdf11
    Offline

    pdf11 New Member

    Joined:
    Apr 30, 2011
    Messages:
    14
    Likes Received:
    0
    [Jan 14, 2012]
    hello again!!!
    just an update....
    checked for air bubbles at tee-piece, i presume thats the part that clips on top of the fuel filter, no bubbles seen after observing for a while, and the car revs to red line in neutral but not in gear, still only 3500. did a trip at weekend at a steady 70-75 and returned 35mpg, doesnt seem too bad, is this reasonable? still doesnt feel quick in 3,4,5,6. the mrs leon 110 tdi is a lot quiker, she's very competitive and is now taking the micky out of my beloved 2.5!!!! lol
    any others ideas?....
    #10
  12. S4_dan
    Offline

    S4_dan Fire up the Quattro!

    Joined:
    Jan 5, 2006
    Messages:
    1,750
    Likes Received:
    79
    [Jan 14, 2012]
    have you tried to Scan it with vag-com and see what is coming up?
    #11
  13. murran
    Offline

    murran Active Member

    Joined:
    Aug 10, 2010
    Messages:
    1,540
    Likes Received:
    34
    [Jan 17, 2012]
    revs round the revs in neutral but not under load......... is the advance/retard working in the fuel rotary pump? you need to get it on the diagnostics to check it.
    #12
  14. pick master
    Offline

    pick master New Member

    Joined:
    Mar 6, 2012
    Messages:
    1
    Likes Received:
    0
    [Mar 9, 2012]
    Hi thanks for your assistance by PMs
    i had a look at cat and mine was clogged up so cut out and now it pull like a train :)
    i drilled a small hole in front and looked in with enderscope then cut pipe before and after cat and fitted a section of pipe
    i might need to find a cat for MOT
    regards Andy
    #13

Share This Page