1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.5tdi won't rev above 3500rpm?!?

pdf11 Jan 7, 2012

  1. pdf11

    pdf11 New Member

    17
    0
    1
    hi.
    i have a 1999 2.5tdi a4 avant that wont rev above 3500rpm, and isn't that quick getting there. doesnt feel like its in any kind of limp mode, but its as if its 'limited'?. i've unclipped the maf sensor and still no difference. it starts and sounds smooth as it should.
    could anyone shed some light on this as i've run out of ideas
    cheers
     
  2. Bradderz_1988

    Bradderz_1988 Dont replace it, Upgrade it !!

    3,876
    226
    63
    Try blocking off the EGR valve see how that helps it !
     
  3. Bradderz_1988

    Bradderz_1988 Dont replace it, Upgrade it !!

    3,876
    226
    63
    Also try cleaning the maf sensor with brake cleaner.
     
  4. pdf11

    pdf11 New Member

    17
    0
    1
    i've just seen a egr blanking plate on ebay, i'm ordering one and let you know
    thanks for the quick reply
    cheers
     
  5. PAULF

    PAULF Active Member VCDS Map User

    712
    66
    28
  6. pdf11

    pdf11 New Member

    17
    0
    1
    Right.....cleaned maf sensor, de-coked turbo vanes with mr muscle, and blocked off egr valve. 1st and 2nd gear rev fine, but only to 3500rpm. 3rd - 6th still not quick, doesnt seem to be a limp mode just feels lazy getting there compared to 1st and 2nd, but still only revs to 3500, wont go past....running out of ideas as the engine runs sweet as a nut, starts fine, but at the moment its like theres a limiter on it?
    any help would be greatly appreciated....
    cheers
     
  7. PAULF

    PAULF Active Member VCDS Map User

    712
    66
    28
    How about looking for air bubbles in the clear fuel line?
    The fuel filter can leak air at the tee-piece, which would be worse under high revs.
     
  8. aragorn

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    17,768
    673
    113
    Does it rev past 3500rpm in neutral?
     
  9. pdf11

    pdf11 New Member

    17
    0
    1
    thanks for the replys. i'll try both suggestions tomorrow....keep you posted
    cheers
     
  10. pdf11

    pdf11 New Member

    17
    0
    1
    hello again!!!
    just an update....
    checked for air bubbles at tee-piece, i presume thats the part that clips on top of the fuel filter, no bubbles seen after observing for a while, and the car revs to red line in neutral but not in gear, still only 3500. did a trip at weekend at a steady 70-75 and returned 35mpg, doesnt seem too bad, is this reasonable? still doesnt feel quick in 3,4,5,6. the mrs leon 110 tdi is a lot quiker, she's very competitive and is now taking the micky out of my beloved 2.5!!!! lol
    any others ideas?....
     
  11. S4_dan

    S4_dan Fire up the Quattro! VCDS Map User

    2,658
    155
    63
    have you tried to Scan it with vag-com and see what is coming up?
     
  12. murran

    murran Well-Known Member

    1,545
    39
    48
    revs round the revs in neutral but not under load......... is the advance/retard working in the fuel rotary pump? you need to get it on the diagnostics to check it.
     
  13. pick master

    pick master New Member

    1
    0
    1
    Hi thanks for your assistance by PMs
    i had a look at cat and mine was clogged up so cut out and now it pull like a train :)
    i drilled a small hole in front and looked in with enderscope then cut pipe before and after cat and fitted a section of pipe
    i might need to find a cat for MOT
    regards Andy
     

Share This Page