1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.5 TDI Cold start issues

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by neilA4, Dec 12, 2011.

  1. neilA4
    Offline

    neilA4 Member

    Joined:
    Aug 8, 2009
    Messages:
    188
    Likes Received:
    0
    [Dec 12, 2011]
    Hi i'm getting blue smoke from a cold startup, but clears after 10 seconds, also It can take a while to start when it's cold outside. ie +4deg. When it does start it is very lumpy for a few seconds, like running on 4 cylinders but only for a few seconds?

    Also getting a top end rattle which dissapears when engine has run for a while, although this seems to be getting better.

    Starts fine when the engine is warm! no smoke no rattle fires up on first urn of the starter!

    Any ideas? Engine is a 2.5 tdi AKE with 190,000 miles

    Cheers.
    #1
  2. Ads

    Ads

    [Sep 22, 2014]

  3. Mike B
    Offline

    Mike B Member

    Joined:
    Jul 10, 2007
    Messages:
    776
    Likes Received:
    8
    [Dec 12, 2011]
    Are the glowplugs OK?
    #2
  4. neilA4
    Offline

    neilA4 Member

    Joined:
    Aug 8, 2009
    Messages:
    188
    Likes Received:
    0
    [Dec 12, 2011]
    how do you check glowplugs? the plug light comes on and goes off, bit slower to go off when cold.

    ta
    #3
  5. Mike B
    Offline

    Mike B Member

    Joined:
    Jul 10, 2007
    Messages:
    776
    Likes Received:
    8
    [Dec 12, 2011]
    That sounds normal same as mine 04 2.5Tdi Q but I think you can check the current which gives their glow.Otherwise maybe the coolant temp sensor but that would show on VAGCOM
    #4
  6. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,892
    Likes Received:
    477
    [Dec 12, 2011]
    Fuel pump timing, and air leaks in the return pipes from each injector are the only other two possibles really.
    #5
  7. neilA4
    Offline

    neilA4 Member

    Joined:
    Aug 8, 2009
    Messages:
    188
    Likes Received:
    0
    [Dec 15, 2011]
    Well have checked fuel pump timing and it is well in spec.
    Injectors are fine also. Only fault code is for a engine mount.

    So, got some bargain denso glow plugs from ebay £23 delivered for all 6!

    Took ones on left bank out, they were newish ngk and came out easily.

    The ones on the right bank were very old and I had to turn very carefully with lots of wd and loosen/retighten etc.

    Also found that 2 of the leads were loose and not pressed on properly!! Just need a cold morning to test now.

    Will change the oil retention valves under oil filter housing and see if that sorts the occasional tapping. Cams look ok through the fill hole, no grooves but do have wear marks in the surface finish.

    doees the cat have to fully come off to change the retention valves?

    ta
    #6
  8. ADC74
    Offline

    ADC74 Master Baker

    Joined:
    Jan 7, 2011
    Messages:
    146
    Likes Received:
    1
    [Dec 16, 2011]
    Have you got a link to those 'glow plugs' on the bay ?
    £23 sounds well cheap, every set I've looked at have been @ £50 - £60 :ermm:

    Were they 'Denso' or 'Delphi' ?
    Last edited: Dec 16, 2011
    #7
  9. neilA4
    Offline

    neilA4 Member

    Joined:
    Aug 8, 2009
    Messages:
    188
    Likes Received:
    0
    [Dec 17, 2011]
    #8
  10. haytch75
    Offline

    haytch75 Member

    Joined:
    Mar 29, 2011
    Messages:
    167
    Likes Received:
    13
    [Dec 17, 2011]
    Did this solve the smoke too mate?
    #9
  11. DAZ1985
    Offline

    DAZ1985 Member

    Joined:
    Aug 9, 2011
    Messages:
    124
    Likes Received:
    0
    [Dec 17, 2011]
    I run mine on optimax as I thought this would help

    This time round I used normal shell deisel and millers ecomax, it's been better for less smoke on start up but I need run another tank through yet

    Maybe worth a punt for £10 a bottle (treats 10 50l fills) £1 a tank, which I'll probably do once a month, plus it's cheaper to do that over optimax derv
    #10
  12. neilA4
    Offline

    neilA4 Member

    Joined:
    Aug 8, 2009
    Messages:
    188
    Likes Received:
    0
    [Dec 17, 2011]
    has not smoked on startup since, engine runs so much better from cold.

    I just chuck in asda diesel, £1.36 round here
    #11
  13. DAZ1985
    Offline

    DAZ1985 Member

    Joined:
    Aug 9, 2011
    Messages:
    124
    Likes Received:
    0
    [Dec 17, 2011]
    Got the link to these glow plugs mate?
    #12
  14. neilA4
    Offline

    neilA4 Member

    Joined:
    Aug 8, 2009
    Messages:
    188
    Likes Received:
    0
    [Dec 17, 2011]
    look in post no8:sm4:
    #13
  15. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,892
    Likes Received:
    477
    [Dec 17, 2011]
    These are probably made by the very same people who make the oem ones, my only concerns would be they're more prone to snapping when the time comes to take them out :(
    #14
  16. ADC74
    Offline

    ADC74 Master Baker

    Joined:
    Jan 7, 2011
    Messages:
    146
    Likes Received:
    1
    [Dec 17, 2011]
    Well I've just ordered a set, bit of a bargain for just over £20.
    I've got no evidence in the service history of mine ever being changed so I guess I'll worry about trying to get them out in another 100k.
    #15
  17. neilA4
    Offline

    neilA4 Member

    Joined:
    Aug 8, 2009
    Messages:
    188
    Likes Received:
    0
    [Dec 17, 2011]
    I put copper grease on threads before fitting. Just be very carefull removing the old ones
    #16

Share This Page