1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.5 TDi A6 stutter/ shudder/ splutter between 1200-2000

Discussion in 'Diesel forum' started by deanogtv, Nov 8, 2012.

  1. deanogtv

    deanogtv New Member

    Joined:
    Feb 8, 2011
    Messages:
    15
    Likes Received:
    0
    In the last few days my A6 2.5 TDi car has developed a stutter/hesitate under acceleration and high speed cruising almost like having a large flat spot that lasts around 1/2 a second, every 2 or 3 seconds.

    Most noticeably, this happens on the motorway under normal driving whereby at 1500 -2000 rpm the engine power dips then returns quickly, this was constant on my 1 hour drive home just now. There are no engine warning lights on the dash but it felt like a mis-fire.

    The problem seems to happen throughout the rev range, there is quick dip in power and in the rpm then it will gather some power to accelerate then happen again and again. If I pull away from a round about slowly the problem isnt too bad but if I were to gun it, the engine would cough and splutter untill I backed off the power.

    Last night driving home up the M11 she struggled past 50mph, first morning she is fine albeit when I stick my foot down for hard acceleration.

    I have done some research but can't find much regarding this same issue, has anyone got any experience with this?

    Any thoughts would be helpful

    Thanks

    DC
     
  2. Advert Guest Advertisement


  3. adamss24

    adamss24 Well-Known Member

    Joined:
    Jul 3, 2007
    Messages:
    4,316
    Likes Received:
    345
    What year is that ? Any fault codes ?
     
  4. tullA6

    tullA6 Mean Green Machine

    Joined:
    Mar 24, 2011
    Messages:
    25
    Likes Received:
    1
    Shudder Fixed...........i had similar problem on my A6 2002, initially tought is was teh clutch so got that done ( expensives buy needed doing anyway!!0 still didnt fix the shudder. Left it to my mechanic and after a lot of research and suggestions to him from me, the following seems to have been the solution,

    1.fit new fuel filter
    2.Clean fuel pressure sensor ( no idea where it is so dont ask..;-)) which had a covering of oil, i am told interfered with the rate of fuel input especially under hard accelloration, which lets face it you want when overtaking etc!!
    anyway she is flying now, and hopefully willbe upgrading to a 2008 in next week or so, so i can sell now safe in the knowledge that it is not a lemon!!!

    hope his helps
     
  5. adamss24

    adamss24 Well-Known Member

    Joined:
    Jul 3, 2007
    Messages:
    4,316
    Likes Received:
    345
    Your fuel filter was clogged up, sometimes ABS and traction light comes on the dash as well... Good to know your mechanic did not take a stab in the dark but used common sence and started with the cheapest fix first !
     

Share This Page