1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.0 TDI Random Stutter

Discussion in 'Diesel forum' started by Bing_IRL, Feb 14, 2009.

  1. Bing_IRL
    Offline

    Bing_IRL Member VCDS Map User

    Joined:
    Dec 2, 2008
    Messages:
    34
    Likes Received:
    0
    [Feb 14, 2009]
    Hi Guys,

    Seems that I may have a problem somewhere and need some advice. I have an A4 B7 2.0TDI (33000 miles on the clock)that gives a little stutter randomly. I can be accellerating in 2nd gear or cruising in 5th but can still feel power drop for a split second. Car drives/performs fine otherwise but every couple of days this happens & am a little worried. Any ideas?

    Cheers,
    Bing
    #1
  2. Ads

    Ads

    [Oct 22, 2014]

  3. dunk
    Offline

    dunk Member

    Joined:
    Oct 22, 2003
    Messages:
    765
    Likes Received:
    1
    [Feb 14, 2009]
    could be a blocked fuel filter - mine gave intermittent stumbling / loss of power and its very cheap to do, but if you dont flush the new one full of fuel it can take 1/2 hour of cranking to get the engine to fire afterwards - i think its one thing worth paying a dealer or vag specialist garage to do
    #2
  4. Bing_IRL
    Offline

    Bing_IRL Member VCDS Map User

    Joined:
    Dec 2, 2008
    Messages:
    34
    Likes Received:
    0
    [Feb 14, 2009]
    Thanks Dunk. I'll pop up to them on Monday so. That couldn't be diagnosed via the OBD before they open anything up could it? Local dealers are a bit sloppy & I prefer to keep them as far away as possible.
    #3
  5. dunk
    Offline

    dunk Member

    Joined:
    Oct 22, 2003
    Messages:
    765
    Likes Received:
    1
    [Feb 15, 2009]
    no if its fuel starvation then i dont think vagcom will show up anything useful
    #4
  6. Bing_IRL
    Offline

    Bing_IRL Member VCDS Map User

    Joined:
    Dec 2, 2008
    Messages:
    34
    Likes Received:
    0
    [Apr 6, 2009]
    Hi Guys,

    Finally got around to changing the fuel filter & set about removing the old one. This has to be one of the simplest things to do, that is if you have the right part :). Bloody motor factors guy gave me the wrong filter!!

    Anyway, since everywhere's closed till the morning I emptied out the contents of the old filter & there isn't even one partical of dirt in it. Do you guys know if I can just stick in the old one again or will the dirt just stay inside the filter?

    Cheers,
    #5
  7. 347
    Offline

    347 Member VCDS Map User

    Joined:
    Sep 30, 2006
    Messages:
    293
    Likes Received:
    24
    [Apr 11, 2009]
    hi there , having simular issues with my a3 tdi

    have you sorted yours out yet ?
    #6
  8. tdisportuk
    Offline

    tdisportuk Member

    Joined:
    Mar 20, 2009
    Messages:
    460
    Likes Received:
    0
    [Jul 22, 2009]
    i was told it was the 'injector loom' which causes this stutter and needs to be changed after some time. Has the stutter ever happend in idle?

    the engine mounts in the car are not very clever too any minor rumble, you can feel it!
    #7
  9. sticky
    Offline

    sticky New Member

    Joined:
    Jul 21, 2009
    Messages:
    7
    Likes Received:
    0
    [Jul 22, 2009]
    ive got a tdi dsg with similar problems too!

    only happens in mine when mobile
    its smooth when idle
    Last edited: Jul 22, 2009
    #8
  10. JimC64
    Offline

    JimC64 Active Member

    Joined:
    Apr 22, 2009
    Messages:
    244
    Likes Received:
    28
    [Jul 23, 2009]
    [​IMG]


    dunno if I'm glad I came across this or not.....

    I have the same thing in my 2.0 Tdi A6.
    It was fine, but I've been having lots of problems with losing coolant ( see my thread in the A6 section ) and have complained repeatedly resulting in the dealer replacing the cylinder head. Whilst they were at it and as the car has covered 60k I got them to do the timing belt.
    Car comes out of the garage has this stutter, usually in lower gears, say 2nd and 30mph and 3rd at maybe 35mph.....just alittle hesitation, almost barely noticeable....BUT IT IS THERE!
    I've noticed watching the rev counter which previously sat at a rock steady 800rpm.....now can be steady then waver between say 750rpm and 900rpm now n again.
    I've also noticed an oil leak that wasn't there before.....ITS GOING BACK..

    I'll update what I find

    Jim
    #9
  11. JimC64
    Offline

    JimC64 Active Member

    Joined:
    Apr 22, 2009
    Messages:
    244
    Likes Received:
    28
    [Jul 23, 2009]
    [​IMG]


    took the car in today.....oil leak definitely still there ( tech thinks its may be the head gasket? ).....decided to keep the car in to check properly and gave me an A4 2.0tdi (09) as a loaner.
    They're gonna check the hesitation / stutter while its in and also refit the drivers side wheel well liner properly.:motz:
    I'll keep you updated as to what they find and how it goes from here

    Jim
    #10
  12. JimC64
    Offline

    JimC64 Active Member

    Joined:
    Apr 22, 2009
    Messages:
    244
    Likes Received:
    28
    [Jul 29, 2009]
    [​IMG]



    UPDATE As you know the cylinder head has been replaced under warranty around a couple of weeks ago.
    I've since had an oil leak that wasn't there before which its been in for a few times and also a slight hesitation in the lower gears at around 3000rpm almost like a slight misfire which caused concern.
    The cars been back in for diagnosis and just had a call to advise the following.....
    They've found a a problem with the camshaft which seems to have been tearing the seal. They've already replaced the seal and found this issue as a result of that process.
    They are now going to replace the cylinder head AGAIN and also the twin fuel pump I think they said....something about the oil contaminating the fuel if I remember correctly....The result is that the car will be with them for another 4-5 days or so and then hopefully all will be good.

    Got an 09 plate 2.0 tdi sline avant at present - not a bad car although a little underpowered, but looking forward to getting back into my A6

    As much of a pain as it is with all the toing and froing....the dealers have been pretty good as sorting the issues and communicating with me as well
    #11
  13. johnmccracken
    Offline

    johnmccracken New Member

    Joined:
    Aug 3, 2009
    Messages:
    5
    Likes Received:
    0
    [Aug 3, 2009]
    I have a a3 2.0 tdi b7 which has a stutter/misfire at 2800 rpm which appears occassionallly. Audi haven't been able to sort it.
    #12
  14. JimC64
    Offline

    JimC64 Active Member

    Joined:
    Apr 22, 2009
    Messages:
    244
    Likes Received:
    28
    [Aug 10, 2009]
    [​IMG]


    Hi all...had a few problems with my 07 A6 2.0 tid which have included cold / non start issues and loosing coolant among them.
    Having taken advice I've visited the dealer many times re the low coolant issue and they've replaced the cylinderhead around a month ago. Since that time I've experienced an oil leak that wasn't there before and the engine hesitation as mentioned......usually in lower gears 1st through to 3rd, sometimes 4th and around the 2000rpm mark, there's a slight flutter / hesitation in picking up, more noticeable at low speeds.
    Took it back to the dealer and complained - They've since fitted another new cylinder head as the cam shaft was out of spec and caused a problem with a seal seemingly.
    Car was in for around 8 days or so for this to be done and I wasn't best pleased to say the least.

    The issue now???
    Since I've had the car back Friday I think it was I've suffered with the same engine hesitation - something is definitely NOT RIGHT.
    The other issue is that on Sat am and early today on first start up the car wil not fire......almost like water in the fuel or low battery where it just turns n turns and eventually catches[​IMG][​IMG]

    I'm gonna be on the phone to them tomorrow and see where we go from here.

    I'll keep you guys updated

    Thanks

    Jim
    #13
  15. theo289
    Offline

    theo289 Member

    Joined:
    Oct 31, 2012
    Messages:
    285
    Likes Received:
    11
    [Jul 11, 2013]
    Hi,

    I have exactly the same issue with my car. Did you manage to get to the bottom of this fault?
    #14

Share This Page