1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.0 TDi Help

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by major, Nov 4, 2006.

  1. major
    Offline

    major New Member

    Joined:
    Nov 4, 2006
    Messages:
    3
    Likes Received:
    0
    [Nov 4, 2006]
    My 5 month old 2.0 TDI S line has been in the dealership for almost 2 weeks! It started as an intermittent fault, poor idle not always starting first time Then while driving along the motorway I thought the car was about to take off. Road side assist came out and said it was misfiring and got it towed to the garage.

    They have so far replaced an injector the fuel pump and are carrying out some 'tweaks'. I don't feel the garage is keeping me fully informed!

    Has anyone heard of any problems like this with these engines?
    #1
  2. Ads

    Ads

    [Dec 21, 2014]

  3. vagman
    Offline

    vagman Member

    Joined:
    Feb 21, 2003
    Messages:
    102
    Likes Received:
    0
    [Nov 8, 2006]
    There may be an issue with faulty glowplugs on the 170 version.

    Unlike the coil pack problems with the 1.8T engine a few years ago, not all engines are troubled with this fault.

    I've done a 1,000 miles thus far and it is running like a dream.

    There was a thread on the A3 board a week or so ago, if you wanna check it out.
    #2
  4. major
    Offline

    major New Member

    Joined:
    Nov 4, 2006
    Messages:
    3
    Likes Received:
    0
    [Nov 16, 2006]
    The are changing the cylnder head and numerous other things due to oil in the fuel
    #3

Share This Page