1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1998 1.8 T intermittent engine fault

Discussion in 'A4/S4 forum(B5 Chassis)' started by fin18t, Aug 3, 2009.

  1. fin18t
    Offline

    fin18t New Member

    Joined:
    Aug 3, 2009
    Messages:
    2
    Likes Received:
    0
    [Aug 3, 2009]
    I have a intermittent fault with my engine,

    It will suddenly lose power and i have to rev it quite high to be able to keep moving

    when it starts to do the problem it will idle erratically nearly cutting out but then revving up to 2500rpm and back down to 300 ish.

    if i stop the engine and restart it will be fine for a while, it could be 300 miles or 3 miles before it does it again.

    the engine also seems to run very unevenly sending vibration into the car and some black smoke and liquid comes from the exhaust (only when doing the problem though) but the rest of the time runs smoothly and clean.

    I have had the car plugged in at a main dealer and there are no faults logged.

    It seems to do it more when the fuel tank is below 1/2.

    I have been told it might be the MAF sensor??
    #1
  2. Ads

    Ads

    [Oct 2, 2014]

  3. Fraser
    Offline

    Fraser Member

    Joined:
    Aug 31, 2003
    Messages:
    584
    Likes Received:
    2
    [Aug 3, 2009]
    yep sounds like MAF
    #2
  4. docurley
    Offline

    docurley Moderator Staff Member Moderator

    Joined:
    Dec 12, 2003
    Messages:
    3,859
    Likes Received:
    25
    [Aug 3, 2009]
    I might even suggest the coolant sensor.
    Last edited: Aug 3, 2009
    #3
  5. aragorn
    Online

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,622
    Likes Received:
    321
    [Aug 3, 2009]
    it could be quite a few things.

    Ignition amplifier dropping sparks for instance, or as has been said MAF or CTS.

    I would get a vagcom scan done and see if it shows anything up.
    #4
  6. fin18t
    Offline

    fin18t New Member

    Joined:
    Aug 3, 2009
    Messages:
    2
    Likes Received:
    0
    [Aug 3, 2009]

    As I said in my post I have had it plugged in at a main dealer and no faults came up....

    So it looks like i need a MAF... anyone got any advice where i can get one? some guy on ebay is selling them for about £30 seems a bit dodgy...
    #5
  7. Fraser
    Offline

    Fraser Member

    Joined:
    Aug 31, 2003
    Messages:
    584
    Likes Received:
    2
    [Aug 3, 2009]
    the dealer or eurocarparts

    get a proper bosch - anything else is not worth it and will cause problems
    #6

Share This Page