1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

17522 Oxygen (Lambda) Sensor

Discussion in 'VCDS (formerly VAG-COM) forum' started by RussUK, Mar 26, 2007.

  1. RussUK
    Offline

    RussUK Member

    Joined:
    Mar 6, 2007
    Messages:
    41
    Likes Received:
    1
    [Mar 26, 2007]
    Hi all,

    Was hoping anyone could give any advice on the following error - it has come up twice in the last two weeks, about 1000 miles between each time.

    1 Fault Found:
    17522 - Oxygen (Lambda) Sensor: B1 S2: Internal Resistance too High
    P1114 - 35-10 - - - Intermittent

    I'm thinking of purchasing a new lambda sensor and getting it replaced.

    Just in case anyone has had the same I thought I'd post on here first.

    Many thanks,
    #1
  2. Ads

    Ads

    [Nov 27, 2014]

  3. Uwe@Ross-Tech
    Offline

    Uwe@Ross-Tech Member

    Joined:
    Oct 7, 2006
    Messages:
    130
    Likes Received:
    0
    [Mar 28, 2007]
    I would double-check all connectors between the sensor (the post-CAT one) and the ECU first. Maybe apply some contact cleaner / conditioner.

    -Uwe-
    #2
  4. finesse
    Offline

    finesse Active Member VCDS Map User

    Joined:
    Aug 15, 2006
    Messages:
    2,811
    Likes Received:
    10
    [Aug 4, 2010]
    Sorry for bring up this old thread. I have the same issue?

    Uwe, what contact cleaner and where do apply it. How do you check the ECU?

    Thanks
    #3
  5. suthsy
    Offline

    suthsy New Member

    Joined:
    Feb 27, 2010
    Messages:
    23
    Likes Received:
    0
    [Aug 4, 2010]
    I have a the same issue... :(

    00-Steering Angle Sensor -- Status: OK 0000
    01-Engine -- Status: Malfunction 0010
    02-Auto Trans -- Status: OK 0000
    03-ABS Brakes -- Status: OK 0000
    08-Auto HVAC -- Status: Malfunction 0010
    09-Cent. Elect. -- Status: OK 0000
    15-Airbags -- Status: OK 0000
    16-Steering wheel -- Status: OK 0000
    17-Instruments -- Status: OK 0000
    19-CAN Gateway -- Status: OK 0000
    22-AWD -- Status: Malfunction 0010
    25-Immobilizer -- Status: OK 0000
    42-Door Elect, Driver -- Status: OK 0000
    44-Steering Assist -- Status: OK 0000
    46-Central Conv. -- Status: OK 0000
    52-Door Elect, Pass. -- Status: OK 0000
    56-Radio -- Status: OK 0000
    76-Park Assist -- Status: OK 0000

    2 Faults Found
    17548 - Oxygen (Lambda) Sensor; B2 S2: Internal Resistance too High
    P1140 - 008 - Implausible Signal - MIL ON
    16544 - Oxygen (Lambda) Sensor B2 S2: No Activity
    P0160 - 004 - No Signal/Communication - Intermittent
    Readiness: 0000 0000

    Address 08: Auto HVAC
    Cannot be reached

    any help, ideas, suggestions.... would be much appreciated...
    #4
  6. bearthebruce
    Offline

    bearthebruce Ross-Tech, LLC

    Joined:
    Jul 4, 2006
    Messages:
    332
    Likes Received:
    17
    [Aug 6, 2010]
    Let's go back to basics. A high resistance indicates non-connection or a broken heater element in the sensor. Before spending money on Oxy sensors, check the connections from the ECU to the rear O2 sensor. Uwe has suggested you go get some contact cleaner for electrical contacts because often the contacts in the connectors under the car get fouled by water and corrosion. Surely an auto parts store near you would be able to recommend a contact cleaner.

    Once you have eliminated connection issues, then you move on to replacing the O2 sensor. Before you replace it, you get a DVOM and measure the resistance of the heater. If it is not in spec, you replace it.

    Now I know you will ask - what's the spec? Answer: depends on the sensor. A repair manual for your car or the erwin.audi site should have that information.

    Make sense?
    #5
  7. suthsy
    Offline

    suthsy New Member

    Joined:
    Feb 27, 2010
    Messages:
    23
    Likes Received:
    0
    [Aug 6, 2010]
    Yes perfect sense. Thankyou for your reply. Already ordered some contact cleaner, it will be delivered tomorrow. As for checking the spec, i will look into that tomorrow too. Thanks for your help.

    Recently had my car resprayed and alloys refurbished, would the fumes from the paint trigger the sensor to go off?
    #6
  8. suthsy
    Offline

    suthsy New Member

    Joined:
    Feb 27, 2010
    Messages:
    23
    Likes Received:
    0
    [Aug 9, 2010]
    so... after weeks of worrying how much money i will have to spend o2 sensors, cat converters, new MAF etc... i have found the problem as to why the exhaust emission light decided to show...

    the wires joining the o2 sensor on the left cat had become unstuck and left hanging above the exhaust, eventually they completely burnt through from when the exhaust became hot, which then triggered the o2 sensor as it was unable to function properly. i have pictures to show but dont know how to paste them into the post :think:
    #7

Share This Page