1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

170 TDI Glow Plug Relay Fault

PJLarge Dec 23, 2006

  1. PJLarge

    PJLarge Member

    71
    1
    6
    To all those the the TDI 170 that are waiting for parts for the emmissions light problem, I had mine fixed yesterday so presumably parts are now freely available. Hassle your dealer now!

    Phil.
     
  2. southpaw66

    southpaw66 Member

    166
    1
    16
    Yep, Mine too! It's strange not having the emissions light on anymore.

    Merry Christmas
     
  3. Datastorm

    Datastorm Member

    63
    21
    8
    Had mine changed on the 22nd Dec @ my local Audi dealership without issue.

    I didn't realise this was a common problem with this model, but I'm guessing quite a few of you guys have had a similar problem.
     
  4. Vertigo1

    Vertigo1 Well-Known Member

    3,381
    542
    113
    Out of interest, what were the exact manifestations of this problem? I'm assuming mine came "pre-fixed" as it's only two weeks old but you never know :)
     
  5. duncangoncalves

    duncangoncalves Member

    34
    0
    6
    Yea whats the story with this ? had mine for 2 months nearly! is it something that is waiting to happen I'm already cheesed off with my car it's been back to te dealer 4 time's to try sort the air con!! don't tell me I'm going to have to go back again :'(
     
  6. Nelson_R32

    Nelson_R32 Member

    305
    2
    16
    Just litterally a faulty Glow Plug relay that came from factory! Nothing more really! :p
     
  7. southpaw66

    southpaw66 Member

    166
    1
    16
    Unless you have a emissions warning light don't worry. It's a 20min while you wait fix if required. It was just that there was no availability of parts as Audi changed suppliers before Xmas.
     

Share This Page